• It works well after a tweak. Just place the WP_REDIS_PASSWORD at the top of your wp-config.php file. This might be before the WP_CACHE.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Thanks for the stars 🥰

    Fun fact side note: WP_CACHE is unrelated to Redis, it’s relevant for page caching using the advanced-cache.php drop-in.

    Thread Starter noeyx

    (@noeyx)

    Thanks for the fun fact. I just want to add that all of the connection parameters should be placed before the database name at the top of wp-config.php for consistency. When I logout, I then become unable to login when this plugin is enabled and/or object-cache.php is in the wp-content folder. Thankfully, the solution can be found here:

    https://wordpress.org/support/topic/cant-login-after-enabling-object-cache/page/2/

    The rename-command in redis.conf conflicts with this plugin so I have to comment those out. I hope this can be supported in the near future since the rename-command is a recommended security practice.

    Plugin Author Till Krüss

    (@tillkruess)

    That’s an ancient and outdated security “measure”. It’s much better to use Redis 6 ACLs to make sure WordPress can only do so much in Redis.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Works well so far’ is closed to new replies.