Support » Plugin: Disable Welcome Messages and Tips » Works well, only one gotcha

  • Hi Jules,

    Thanks for making a plugin to suppress all the latest and greatest WP nags 😉

    Only one gotcha, The options menu in the “three dots” menu upper right is not showing anymore. Luckily it isn’t needed often, but this can become a problem for people who want to switch on advanced panles like, Custom fields.

    Probably it uses the same CSS class as the dreaded welcome message which makes it hard to fix. Maybe worth to put a note the on the plugin.

    Bart

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jules Colle

    (@jules-colle)

    Thanks for the feedback, Bart.

    I quickly created this plugin to include in my dev containers for some integration testing, but I’ll be happy to gradually make it better so it becomes useful for everyone who gets annoyed with the fast pace in which WordPress keeps adding beginner-friendly features.

    • This reply was modified 10 months, 2 weeks ago by Jules Colle.
    Thread Starter bart88

    (@bart88)

    Hi Jule,

    Your work and the your quick release.

    I am not against begier features, but a advanced user should be able to turn the of permanently, which is not the case with the fullscreen and modal/popup.

    Even the dev community is divided on how theses implemented. Interesting reading:

    Fullscreen mode enabled by default in the editor

    Plugin Author Jules Colle

    (@jules-colle)

    you’re right. In order for this plugin not to become too opinionated, I’ll have to add a settings page.

    Thread Starter bart88

    (@bart88)

    Sorry for all the spelling errors in my last comment.

    I ment to say, I am really against the way the core team has implemented the full screen option. Having default full screen should be a user option not a default. Even a couple of wp core devs have that opinion. However Matt really love the fullscreen editor and pushed this default fullscreen feature in the update at a last notice….

    So no plugin setting needed 😉

    There also might be a way around the gotcha about the settings menu not showing up. I found it in a stackexchange post you already replied on

    https://wordpress.stackexchange.com/questions/334559/deactivate-gutenberg-tips-forever-not-gutenberg

    It’s the “Update #2” part. I didn’t got the time yet to test it, but it might work to block the tips popup and leave the options menu accessible.

    If that turns to be the case and you are willing to put it into your plugin, you will be apprized by many 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Works well, only one gotcha’ is closed to new replies.