Support » Plugin: IP Geo Block » Works too well – Blocked my wp-admin myself

  • Resolved berlinicker

    (@berlinicker)


    Hello tokkonopapa,

    Thank you for developping this plugin. I really appreciate its functionality.

    However, having installed and configured it today, I found the following problem: In “Validation target settings” I replaced the original important files to block “wp-login.php,passwd” by “wp-login.php,wp-admin”. I am a newby and I noticed only afterwords that this may cause trouble because if I want to save any changed settings within this tab, the backend shows me “Forbidden”. Unfortunately, I blocked my own wp-admin. 🙂 Even if I want to replace “wp-admin” by “passwd” again, I cannot do so, because the backend will show me “Forbidden”. Nevertheless, I can log in into my backend.

    I have already tried a lot to restore the original settings. I made backups on my webserver, I uninstalled and reinstalled the plugin but unfortunately the settings stay the same. Even if I click on “Remove all settings at uninstallation” nothing will change because I have to save this first which is not possible because of the reasons above… So it is kind of a vicious circle…

    Here is some background information about my settings:
    – I whitelisted the countries in which I work.
    – I blocked by country the xml-rpc, the login form, the admin area, the admin ajax/post, the plugins area and the themes area (and the important files wp-config.php,wp-admin, see above).

    Do you have a solution to my problem I have not tried yet? Thanks in advance for your help.

    Regards,

    Berlinicker

    https://wordpress.org/plugins/ip-geo-block/

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Works too well – Blocked my wp-admin myself’ is closed to new replies.