Support » Plugin: URL Coupons for WooCommerce » works just for logged users?

  • Resolved eltoine

    (@eltoine)


    Hi, we use your plugin URL Coupons for Woocommerce and I see that it does just work, when a client is logged in? Why is it not possible for customers who are not logged in?

    This should also work for these clients. Can you please help me?

    Please check:

    https://shaveclick.ch/?coupon=test

    you can create then an account to see that it works just with logged users.

    Thanks

    Elton Ferati

    The page I need help with: [log in to see the link]

Viewing 8 replies - 16 through 23 (of 23 total)
  • Here is the link to download screen record:

    https://transferxl.com/08vcyK4sVNjSs5

    I tried it with my mobilephone, try also with your mobiephone.

    shaveclick.ch/?coupon=test

    Thanks for your answer / help!

    ..I wrote to WP Rocket and they answe that: (for your information) maybe you can help us more:

    “Hi,

    N… from WP Rocket here. Thanks for contacting the support 🙂

    Sorry for the issue you are having!

    I checked your site and was able to reproduce it.

    I am not sure yet what might be causing it, but adding the shaveclick.ch/?coupon=profity15 string to the Never Cache URL wouldn’t solve this.

    Question mark after slash means that it is a query string. WP Rocket doesn’t cache query strings by default, that is why it didn’t let you add the URL to the text area.

    I checked further, and I can see that this query string redirects your visitors immediately to the default domain shaveclick.ch which is cached. I also checked the check-out page https://shaveclick.ch/warenkorb/, and it is not cached – which is a proper setup.

    I suspect that when your visitors are following the link, a cookie for the discount should be set in their browser. It is possible to exclude pages from caching when a certain cookie is set by adding the cookie value to the Never Cache Cookie text area. But at the moment I cannot tell you what cookie it is. And I am not sure if this would solve the issue.”

    Maybe these information will help you finding out why its causing the problem. 🙁

    Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @eltoine,

    Ok, let’s try it with a cookie, as suggested. Please update the plugin to the latest v1.2.7. Now I’ve added new “Advanced: Extra cookie” options to our plugin settings. Try enabling the checkbox there. After that you need to add this cookie to “Never Cache Cookie” option somewhere in WP Rocket. Our cookie name is alg_wc_url_coupons. Please give it a try and let me know if that makes any difference.

    Hi

    I updated plugin, i enabled checkbox and I added the coockie to Never Cache Cookie but sometimes it still doesnt show product in the cart. I also deactivated WP Rocket, still same problem.

    When I try at desktop, it works normally well, but when I try at mobile device I get this problem.

    Could it be possible that when I click maybe too fast at the Add to Cart button that it doesnt work correct? Does the cookie load immediately or do I have to wait for a certain time before clicking at Add to cart button?

    I ask that cause sometimes it works and sometimes it doesnt.

    But we have to be sure that it works always.

    Thanks.

    …I see that by clicking the coupon url, I get redirected to the main page http://www.shaveclick.ch without the url after the slash / maybe this causes the problem, is it not possible to make the whole url visible without redirection to the main page?

    Its just a idea..

    For your information, I also changed the url to: https://shaveclick.ch//?alg_apply_coupon=test

    I left it standard now like in the plugin description..

    sorry https://shaveclick.ch/?alg_apply_coupon=test

    I mean, not 2 slashes //

    Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @eltoine,

    If you mean to leave URL as https://shaveclick.ch/?alg_apply_coupon=test after the coupon is applied – this is not good, as in this case, if user reloads the page, plugin will try to apply the coupon again (i.e. “Coupon is already applied” message will appear). There is “Redirect URL” option in Pro version – we could set it to “Redirect to custom local URL” and then set “Custom local URL” option to something like https://shaveclick.ch/?alg_apply_coupon_applied=1. This could help if the problem is really in caching, which I’m not sure about… And by the way, I did try visiting your site (from incognito window), but unfortunately, didn’t manage to reproduce the issue – it seems to be working fine here, and I need to add product to the cart only once.

    Plugin Author Algoritmika Ltd

    (@algoritmika)

    If anyone else has a similar problem – as we’ve figured out, it was a compatibility issue with “WP Rocket” plugin. We’ve added new “WP Rocket: Disable empty cart caching” checkbox option to the plugin – it seems to be solving the problem.

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.