Support » Fixing WordPress » Works in Firefox but not Internet Explorer

  • HELP!!! Now here’s a NEW problem:

    checkou my blog at http://howiebarte.com/WordPress

    In Firefox it looks fine, but in internet explorer, this is what people see:

    What’s Seven Billion Taxpayer Dollars Among “Friends”?
    September 25th, 2008
    <!–[endif]–>

    <!–[endif]–> st1\:*{behavior:url(#ieooui) }
    –> <!–[endif]–>

    <!–[endif]–>

    <!–[endif]–>

    <!–[endif]–>

    <!–[endif]–>

    <!–[endif]–>

    <!–[endif]–>
    <!–[endif]–>
    How do I fix this?????

    HELP!!!!

    <!–[endif]–>

Viewing 11 replies - 1 through 11 (of 11 total)
  • Stop copy/pasting from Word.

    or use the paste from word function

    Well, I deleted all the code at the beginning of the post, and that solved the problem. I used the Paste From Word Function (thanks for pointing it out to me) to resubmit the post first, but it just brought the code along with it.

    Is it supposed to do that?

    Also, is there a technical explanation for why this was a problem for IE (which i hate, anyway) but not for Firefox?

    Thanks in advance.

    Is it supposed to do that?

    Nop. But as a rule of thumb, everything I copy from Word, first passes through NotePad (The best App EVER !! 🙂 )

    And If you want a second rule of thumb – Don’t use Word at all (OpenOffice is much more reasonable when coming to Cut & Paste)

    Also, is there a technical explanation for why this was a problem..

    yes, and you can find it here if you are really interested.
    http://tinymce.moxiecode.com/punbb/viewtopic.php?id=12405

    I’m getting the same on my blog http://jordanspharmacy.ie/hp_wordpress/

    I don’t use MS word at all. Most of my posts are directly into the “Write a post” box or by copying and pasting from OpenOffice 2.4.

    Please don’t ask me to clean up my code as I do not have a clue about this. I fixed an earlier problem by copying the text to OpenOffice, making it all Verdena size 10 and re-posting, editing the time stamp and deleting the old page. I did this with every page going back until the problem resolved. It sorted the problem in Firefox but not IE.

    Read above …
    especially the parts that say :

    ..use the paste from word function..

    and

    ..first passes through NotePad …

    I saw this above

    .use the paste from word function..

    But I cannot find this on the “Write a post” or “write a page” screen. Am I missing something or in need of an upgrade?

    Thanks

    you probably are missing something ..
    It is a small “W” like the word Icon on a “pasting clipboard”, in your writ panel.
    If you still do not see it , click Alt+Shift+Z, or press on the expand options icon (small colored squares next to the images icon)

    I couldn’t find this.
    But I turned off the

    Use the visual rich editor when writing

    option in users. I opened the first problem post for editting, cut to Notepad and just pasted the post from notepad with no formatting. Saved and now it is visible in IE7 & 6.
    Now all I have to do is to edit just about every post (100) at present and repeat.
    Slow & tedious but at least it works.

    Thanks again.

    and how do you plan to make Bold, Italic, or any other formatting without the visual editor?

    There are still some basic formatting tags over the post window. I just high light the piece I want

    formatted

    and click the tag above. (like here)
    There is still a lot of features that I haven’t figured out how to do such as changing the font size etc but I will get there.
    At least it is readable now.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Works in Firefox but not Internet Explorer’ is closed to new replies.