WordPress.org

Support

Support » Plugins and Hacks » Easy FancyBox » [Resolved] Works fine first time, but not second time ?

[Resolved] Works fine first time, but not second time ?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author RavanH

    @ravanh

    Hi kibbel6400, that’s indeed a strange effect. I have not seen that before… I’ll try to find out what’s going on.

    Plugin Author RavanH

    @ravanh

    Ah, got it… You’re using the 1.5dev version. This version has a seperate class for inline content. Activate the “Inline content” feature on Settings > Media and change the links so that they use class "fancybox-inline" instead of just "fancybox"

    Hi RavanH

    Thank you for taking time for the issue, but it still doesn’t work 🙁 I click the “Inline Content” on and change the class hmm

    Plugin Author RavanH

    @ravanh

    Hmmm… I see. The jQuery Migrate script that is included by your theme is interfering on fancybox.close() . That script should not be included unless jQuery 1.9+ is used. The current WordPress includes jQuery 1.8.3

    Is there an option in the theme to prevent loading the Migrate script?

    Hmmm i look in the theme option, i can’t see a option to prevent it from loading… 🙁

    Global Options

    Retina Header Image – Uploaded header images are HiDPI images for retina displays, downsize on normal screen devices.

    Fancy Drop-down Menus – Enable transition effects for drop-down menus

    Post Thumbnails – Hard crop post thumbnails
    Note: After changing this option, it is recommended to recreate your thumbnails using a plugin like AJAX Thumbnail Rebuild

    Lightbox – Open image links in a lightbox

    Posts Navigation

    Posts Navigation Labels

    Hey Ravan,

    I’m having exactly the same issue. I’m developing locally, would you need me to put the site live first?

    Plugin Author RavanH

    @ravanh

    @dash, if you’re developing locally, it should not be too difficult to remove the migrate.js script file. Am I wrong?

    Hey Ravan, Cheers for the reply. I’m confused, why would I need to remove the migrate.js script file?

    I’m having a problem with the iframe only working once. The second time I click on the link the video content doesn’t load.

    It’ll take some time as it need to transfer the wordpress database but I can install om a server if that’s easier?

    Plugin Author RavanH

    @ravanh

    Hi dhash, you wrote:

    I’m having exactly the same issue.

    so I replyed with the same answer… Is you theme actually using the migrate.js script? If not, your issue is a different one.

    Hey Ravan

    No my theme doesn’t use migrate.js. I can send you a dropbox link to the files?

    My theme is called Good Space. Do you want me to get it on line so you can have a look?

    Damo

    Plugin Author RavanH

    @ravanh

    Sorry Damo, Unless you have it ready online and I can take a quick look so I can scan for any console errors, I do not have time to debug individual cases.

    If you’re developing locally, you could open up the developer tools in Chrome or Opera browser and check the console or errors tab for any related errors. It might tell you more about where things are going wrong and what conflict might be causing it 🙂

    Hey Ravan

    Just thought i’d post a link to my development site.

    If you click on the 2nd video tile (Clinician Stories) next to the pink support tile. The iframe will open with a video. However the video only shows up the first time. If you close the link and open it up again, there’s no video. Any ideas?

    http://knowpathology.com.au/dev/

    Cheers

    Damo

    I am having the same problem, but with files I am using from soundcloud.
    This is the code:

    <a href="#soundtrack" class="fancybox inline"><img src="http://i.imgur.com/jWoyGwd.jpg"></a>
    <div class="fancybox-hidden">
    <div id="soundtrack" width="300" height="600">
    <iframe width="100%" height="166" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F95255638"></iframe>
    <iframe width="100%" height="166" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F95255640"></iframe>
    </div>
    </div>

    It works fine the first time you click on the image, but if close, and click again soundcloud player will not show up. I am not sure if its something to do with the two iframes I am using or not, but it works perfectly the first time, so I am thinking that may not be an issue.

    The URL is http://medbizmarketing.com and the image is the square ‘Music From the Soundtrack’

    Thanks in advance

    Plugin Author RavanH

    @ravanh

    @dhash and @elementalmedia, it’s a known issue in FancyBox: iframes inside inline content will get cleared after closing FancyBox. To get around this, please use the iFrame mode to display iframes, not the inline content mode.

    @dhash Link to the Vimeo page directly and activate the Vimeo option on your Settings > Media page.

    @elementalmedia enable the iFrame option on your Settings > Media page and create links like this:

    <a href="https://w.soundcloud.com/player/?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F95255638" class="fancybox-iframe"><img src="http://i.imgur.com/jWoyGwd.jpg"></a>

    If you want more than one track in the same player, you might access Sets with /playlists/ (see http://developers.soundcloud.com/docs/api/reference#playlists)

    Thanks for the fast reply.

    I was able to use the widget code from the Set at Soundcloud, so I didn’t have to dig through the entire api setup.

    Everything is working fine now, I appreciate the assist!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Works fine first time, but not second time ?’ is closed to new replies.
Skip to toolbar