Support » Plugin: No Category Base (WPML) » works but wmt gives 404

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    Are you able to navigate with your browser to the URLs?

    Are the dates on the errors GWT is reporting current?

    the new urls working fine in browser
    but the old urls gives me 404 (browser & webmastertools) …

    and yes the dates are current … (27.02.2016)

    Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    Oh you’re saying that the old URLs aren’t redirecting to the new ones. Is that correct?

    jea … that’s correct

    Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    Strange that the old category URLs don’t redirect to the new ones.

    1. Other than activating the plugin, did you make any settings changes to permalinks?

    2. Are you willing to share a URL that isn’t working?

    3. Are you using a caching plugin? If so, can you clear the cache?

    4. Are you using an SEO plugin?

    1. no I did not (but in options / permalinks the category base is empty)

    2. sry, I do not want here

    3. yes, i’m using w3 cache and cache is clean now

    4. yes i’m using all in one seo plugin

    Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    Can you confirm that the problem still exists after clearing the cache?

    problem exits after clearing …

    Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    I have installed All in One SEO and things continue to work for me i.e. the redirects from old categories to new works as expected.

    I also tried clearing the category base value so it would be blank like yours and still things worked.

    Two more ideas:

    1. Deactivate the plugin. Resave your permalinks structure. Reactivate the plugin.

    2. Turn on debugging via the wp-config.php. Maybe there’s a plugin conflict causing an error.

    my actually category base
    http://prntscr.com/a9gufg

    can u tell me how it is normal ? 🙂
    I’ve forgotten it

    how can i turn on debugging ?

    Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    I’m not sure what you’re asking when you say “how it is normal”.

    Here are instructions for turning on debugging: https://codex.wordpress.org/Debugging_in_WordPress

    Note that you don’t want to leave debugging on as it may display messages to your users. Turn it on, access one of the error pages you know about, copy any messages displayed, and then turn the debugging off.

    can’t gebug … when i debug in wp-config:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/trancese/public_html/wp-includes/functions.php on line 3737
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/trancese/public_html/wp-includes/functions.php:3737) in /home/trancese/public_html/wp-includes/pluggable.php on line 1228
    Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    Deactivating, saving permalinks, reactivating didn’t work, right?

    Too bad debugging didn’t reveal anything useful. I’m kind of stuck then on what else to try since we can’t get any more information about what’s causing the problem.

    right, didn’t work …

    that was the original page:
    http://trancesets.me/dj-livesets-livemixes/other-livesets

    after activating plugin:
    http://trancesets.me/livesets/other-livesets

    Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    What was the original category base? It doesn’t look like the old URL has a category base. Usually the category base is /cat/ or /category/ which then disappears with my plugin.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘works but wmt gives 404’ is closed to new replies.