• It works and show code beautifully on pages, But if you copied that code and want to use it, the it shows errors, Looks like it add some spaces,

    I tried it with php shorcode, and when i copied the code from the frontend of the page, It gives Parse error: syntax error, unexpected…

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Alba (a11n)

    (@ctdealba)

    Hi @janothemes

    Our development team took a look at this issue and was able to reproduce it when using Python and Firefox. I have added your report in here and the developer’s findings. Feel free to add more details such as:

    • The browser you are using
    • The section of the code you were copying
    • How are you using the plugin (you mention shortcodes but as far as I know, we are now using Blocks)
    • The whole parse error, preferably with some extra data like the language version (if it is PHP, for instance, the PHP version)

    As a workaround, could you double-click the code and then copy it? When you double-click the code, it will change to a textarea and then the code will work successfully.

    As a second workaround, it looks like it works correctly on Chrome. If you haven’t tried with different browsers, could you try with Chrome?

    Hope this helps!

    Best,
    Alba

    Thread Starter janothemes

    (@janothemes)

    Hi, Sorry for the late response.

    I used mozilla firefox and chrome, i was copying the the whole code not a section of the code. yeah i used blocks eg: [php]</strong>[/php]

    Yeah with double click it works well, But many users just copy it and paste the code to use it. so it will produce error and they will think that errors are in code.

    Plugin Support Gaurav (a11n)

    (@gaurav984)

    Hi again,

    Thanks for the update and no worries on the delay. Also thanks for confirming that the double-click and copy routine works for you.

     yeah i used blocks eg: [php]&lt;/strong&gt;[/php]

    Can you give some details on this? Are you using WordPress Block editor (Gutenberg) Blocks for adding the code on a post, or are you using shortcode / Classic editor?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Works, But if you copy code and wan to to use it show error’ is closed to new replies.