Support » Plugin: Simply Static » Works as should be expected

  • I have had this installed for months hoping to create static sites that could be loaded on AWS S3 storage, but was getting permission errors killing navigation. Not even sure at this moment which options for generation I used since I had tried all three several times. I think the errors were in AWS though, not in this plugin. Once I disabled and deleted the CloudFront distribution, and created the site again from scratch, it all worked fine… just took me nine months to get there. Now I have to go back and redesign my content, and remove the “comments” field I left in one page. It fails with an ugly error, but, it’s explained, it doesn’t work because…. So, I am happy. 100% satisfied this tool does the job. A note on generation, turn off all your plugins, and if you’re using a packaged WP theme, you may have to change that based on the errors you see. Scrolling through the pages of what’s generated is a pain, sequentially, slowly, past all the successful 200 errors to get to the 300s and 400s… jump to the end, and scroll back, it’s quicker. It will reset to page one when the generation finishes, so you can’t look for too long. You could return, but at this point, I just loaded on AWS to see how it worked. It works great! Thank you.

  • You must be logged in to reply to this review.