Support » Plugin: WP2Static » Working well on Windows DEV site

  • It took a few tries to get this working – but we now have a static website ‘copy’ of a DEV WP website that is currently hosted on Azure PaaS, running from an Azure Storage Account.

    The zip file downloaded from the plugin’s UI didn’t have contents listed in folders – but there was another zip file generated within the Azure hosted website folders (in wwwroot/wp-contents/Uploads/). Downloaded this ‘hidden’ zip file, extracted the folder structure and files, uploaded all to an Azure Storage Account with the Static Website feature activated – voila!

    Fabulous – exactly what we were looking for – now we’ll be doing the same for the PROD site. Did another test by changing to a lighter WP theme and child-theme, didn’t deactivate the heavy lifting security plugin or the caching plugin – WP2Static plugin just WORKED!
    All internal and external links resolve correctly…this IS a game changer for us…

    I’m impressed with Leon’s quick responses to my questions – he outlined some issues that needed to be done to the WP website after reading the debug logs he asked me for. He outlined caveats that he hasn’t specifically set the plugin up for working with Windows/IIS – but v 6.6.5 IS working on a serverless Azure Storage Account for us. Brilliant really! Thank you Leon – we’re watching for 7.0 and the add-on Azure options

    • This topic was modified 2 years, 2 months ago by karendean.
    • This topic was modified 2 years, 2 months ago by karendean.
    • This topic was modified 2 years, 2 months ago by karendean.
    • This topic was modified 2 years, 2 months ago by karendean.
    • This topic was modified 2 years, 2 months ago by karendean.
    • This topic was modified 2 years, 2 months ago by karendean.
    • This topic was modified 2 years, 2 months ago by karendean.
    • This topic was modified 2 years, 2 months ago by karendean.
  • The topic ‘Working well on Windows DEV site’ is closed to new replies.