Support » Plugin: SQLite Integration » Working great under PHP 7 with this quick fix!

  • Working great with WordPress 4.7.5 and PHP 7.

    Fix for Query Monitor
    ==================

    The Query Monitor plugin, and some other plugins, uses the $db->use_mysqli bool variable to detect if the driver support PDO (_mysqli functions), which is the case for SQLite Integration. But because the $use_mysqli variable is not defined in the PDODB class, this check fails.

    To fix it, simply declare the variable like this in the PDODB.CLASS.PHP file, right before the constructor function:

    /**
     * @var bool Support PHP MySQL Improved version.
     * @access public
     * @author Guy Dumais (https://guydumais.digital)
     */
    public $use_mysqli = true;
    • This topic was modified 2 years, 4 months ago by  gdwp.
    • This topic was modified 2 years, 4 months ago by  gdwp.
    • This topic was modified 2 years, 4 months ago by  gdwp.
  • The topic ‘Working great under PHP 7 with this quick fix!’ is closed to new replies.