Support » Plugin: Super Page Cache for Cloudflare » Working for static page but not dynamic pages.

  • I get the following error on a woocommerce website:

    Page caching is working for static page but seems not working for dynamic pages.

    What could be the problem?

    I also have w3 total enabled, but the issue does not disappear if I temporarily deactivate it.

    There seem to be no rules in .htaccess that would cause this also.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @johns0n,
    Can you share your website url where I can see the issue you are talking about?

    Thread Starter JohnS0N

    (@johns0n)

    Thanks for your fast response. Sure, it’s on funftesrad.com.

    • This reply was modified 1 year, 10 months ago by JohnS0N.

    Hello am aslo facing same issue

    https://prnt.sc/ut8t9h

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @johns0n,
    Looking at your website’s here are a couple of things that stand out to me:
    1. There are a lot of custom cookies being added to your first request. Screenshot: https://i.imgur.com/XzyiNvt.png
    Please note that when Cloudflare sees any request has custom set-cookie header beside the default Cloudflare cookie, it assumes that the content of that webpage is depended on the value of those cookies and hence CF don’t cache the first request and pass it as DYNAMIC.
    In fact, not just your home page but for all pages the first request has some custom set-cookie values seeing which CF is not caching those HTML contents.
    You either have to figure out which plugins are adding those cookies, if you need them or not OR enable the “Stripe Response Cookies” option in the plugin settings and check if our site is still working as you want it to.

    2. I see a header of x-cache and not sure what cache is this. If you are using any other page caching plugin, please make sure to disable that. Please note when using this plugin you are not supposed to use any other plugin for page caching but you can use other optimization plugins to optimize your static files (CSS, JS, Images etc).

    @rrajuraj12 – Please share your website URL without which we can’t check anything.

    Thread Starter JohnS0N

    (@johns0n)

    @isaumya – Thanks for your fast response. It seems I will not be able to install it for this client. Those cookies are needed. And the x-cache is sent from the server cache of the hosting. Varnish. It seems it will be better to use this solution in this case.

    But for another website that is using static content only your plugin blasted the speed out of the roof!

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @johns0n,
    On this website have you tried enabling the option of Strip Response Cookie in the cache tab? If not try that and see if the site still works as intended.

    Yepp, i had the same problem. After i activate this Option the cache test runs fine! Great TY for this hint!!

    • This reply was modified 1 year, 7 months ago by wolf23.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Working for static page but not dynamic pages.’ is closed to new replies.