Support » Plugin: LiteSpeed Cache » Worked Great… Until I Couldn’t Log Back In

  • Wow, talk about a tomato surprise, I installed the LiteSpeed Cache plugin, and everything was working fine… until I was asked to re-login. Then BAM, I was totally locked out of WordPress.

    I tried all the tricks, but apparently LiteSpeed hooks you in a cache loop you can never get out of using the WP login interface.

    I did a quick search through Google and wasn’t surprised to find page after page after page of people with the EXACT same problem. So I hacked it through CPanel so I could log back in, quickly deleted LiteSpeed, and am trying to forget about this nightmare.

    How in the world this program can be on WP with no warning is beyond me, as Google has massive results on this login problem, which would be a huge headache for someone less technically inclined.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    First of all please allow me to apologize for this unhappy experience.

    We did not receive any of such report recently, and only case for such issue was user mis-configuration.

    Could you please join our Slack community or submit a ticket?

    We’d like to know how to reproduce the issue so we can further investigate it , and prevent it from happen again if there is any issue.

    Best regards,

    During my investigation, I had it narrowed down to a cookie issue, as if the LiteSpeed plugin required tracking cookies on its own in order for me to log in. No idea why and never had this happen before.

    I tried to install it on a laptop using an old, defunct website and it did the same thing, and spun me around in a login loop, but when I opened up all cookie options, I was able to login.

    But the site in question is a business site, being run on business computers with browser security and cookie options set by the admin, so there is no way I can (or would want to) open up all browsers settings just to run this one plugin.

    I have also never had a plugin require full cookie access for WP login functionality and I’ve installed tried most of them. No idea what you’re up to with all the cookies either – tracking, phoning home?

    • This reply was modified 5 months, 1 week ago by slangs.
    Plugin Author Hai@LiteSpeedāš”

    (@hailite)

    LSCWP doesn’t require cookie to work. The cookie vary it used is to distinguish different cache copies when a page is to be cached.

    Can you try to turn off Cache Login Page option to see if the infinite loop for login page issue disappears or not? Thanks.

    Doubt if it caused or not by a 3rd party plugin which will redirect if cookie is changed. Sorry to see the unexpected experience though. We are trying to make it better always, and to contribute to WP community as much as we can.

    Also you are always welcome to join WP forum or Slack or our ticket system so that we can try to help.

    No, it was definitely cookie-related so you guys must use cookies for something.

    Once I allowed your cookies to be set, I was able to log in without issue. I turned them off, and deleted the existing cookies and I was immediately back in the locked-out login-loop.

    Have you done testing on Chrome/Firefox browsers with Cookies Off to see how it reacts?

    As for disabling the Cache Login Page (“what tab is that under?” as I may have little time to fool around before I’m locked out again) but it may take me a bit.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    If that is the case, I just did a test.

    I set up a clean WP 5.2.2 on Apache server, in which , no LiteSpeed webserver, nor LiteSpeed cache.

    I disable cookie in Chrome , this WP also fails to login with error message like:

    ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

    And according to WordPress codex , a quote from it

    WordPress uses cookies, or tiny pieces of information stored on your computer, to verify who you are. There are cookies for logged in users and for commenters.

    WordPress uses cookies for authentication. That means that in order to log in to your WordPress site, you must have cookies enabled in your browser.

    So by that means , regardless what server, regardless with or without LSCWP, WP login won’t work without cookie enabled.

    I hope this answers your question why failed to login with cookie disabled.

    Best regards,

    • This reply was modified 5 months, 1 week ago by qtwrk.

    Sorry if I was unclear, but I know WordPress requires cookies for your own domain, but we’re talking about LiteSpeed Cache cookies and turning them off. Otherwise it’s not a test, as you even can’t log into WP with or without plugins.

    To spell it out:

    1) I primarily use Firefox for WP so instructions and results are under this browser.

    2) Enable cookies only for your specific WP URL/domain (under Exceptions), while still having all cookies turned OFF (Block cookies and site data enabled) for everything else.

    3) Make sure you can log in after changes (might have to refresh).

    4) Install LiteSpeed and leave every setting at standard.

    5) Log out and then try to log back in.

    • This reply was modified 5 months, 1 week ago by slangs.
    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    So please correct me if I did anything incorrect.

    This is what I have done:

    1. set up a WP site.

    2. clean FF , block cookie and data as you mentioned.

    https://i.imgur.com/aZCiOsQ.jpg

    https://i.imgur.com/GVt1BqM.jpg

    3. access WP site and add exception

    https://i.imgur.com/ro1DeG6.jpg

    https://i.imgur.com/eNBGXYQ.jpg

    4. login to this WP

    5. now install LSCWP and activate it, leave everything to default settings.

    6. log out and back in again, but I didn’t see any issue.

    Best regards,

    Sounds good, so it looks like an isolated instance on my systems and websites/hosts.

    Did you search on Google? There are a lot of others having the same problem as me with login loops and problems.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Yes, I did some google search with keyword like “litespeed cache can’t login wp-admin” or “litespeed cache wp-admin” , but I only found one case which was user’s mis-configuration where user force cached everything that renders login system not longer work.

    If you have more result , please kindly point us to.

    Also , could you please try :

    1) disable all other plugins.

    2) set “Disable all features” to “ON” in LSCWP setting -> debug tab.

    3) disable all cache settings in LSCWP setting -> cache tab.

    And see how it goes?

    I’d also like to invite you to our Slack community where you can discuss with many other LSCWP users for such issue.

    Best regards,

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this review.