Support » Alpha/Beta/RC » WordPress/plugin upgrade

  • This has probably been brought up somewhere, but a search did not bring up anything.

    It’s great that WordPress 2.7 has an auto core upgrade, but is it possible to upgrade wordpress/plugins without using ftp? Surely it would be easy enough to use file_get_contents to grab the tar.gz file and process it from there without having to deal with ftp.

    I’m sure some people this option won’t work for, but at least give us the option to download directly rather than via ftp.


Viewing 15 replies - 1 through 15 (of 15 total)
  • you can already upgrade plugins from the plugin page automatically. It even tells you when you need an update.

    I must be missing some sort of setting or server setup. I know you can automatically update plugins etc, but when I go to the page I get “To perform the requested action, connection information is required.”

    I have seen on other hosts that it does this automatically though.

    I get this too. It auto fills in the Hostname and Username. I put in my WordPress Password and have FTPS (SSL) check and I do have 990 port open. But when I click Proceed it comes back with:

    Failed to connect to FTP Server and my Hostname. but it don’t say FTPS I don’t have the FTP open.

    I even put in my IP not the name but it still does a connect error.

    -Raymond Day

    I got the same “To perform the requested action, connection information is required” in my 1st blog, but in my 2nd blog it upgrades and don’t ask-me about my password.

    Some help ?

    Same here. I have another blog on the same server that works fine so where is the upgrade or upload setting?

    It’s apparently dependent on the file owner and/or permissions. After making sure I’m the owner of all files in the /wordpress tree the upgrade process no longer asks for ftp connection information and upgrades both wordpress and auto upgrade plugins correctly.

    To make sure the webserver is the owner I use “chown -R www-data:www-data /var/www” on my Debian home server. For Hosted sites it’s unlikely it’s an owner issue. I use a local network to manipulate files so sometimes they end up being created and owned by root.

    From FTP it may be that you need to change all files to 0777 rwxrwxrwx (Owner, Group and Public Read, Write, Execute) using chmod or your favorite FTP program. Then try the upgrade again.

    Once the upgrade is finished it’s a good idea to set permissions back to default, which should be sufficient to do the upgrade correctly. I believe the WordPress default permission is 644 (rw-r–r–) which means owner can read, write and execute, and group and public can only read. For security purposes it’s a good idea to at least be sure you wp-settings.php is set this way in case php barfs and spews your database login information all over the net. 😉

    I’m having trouble with this as well. I’m a bit bothered that there doesn’t seem to be any documentation about how this feature works. I looked through the docs section and the feature isn’t even mentioned. I’ve given www-data write access to the plug-ins directory, but it doesn’t seem to have made any difference.

    edit: I just noticed that it asks for FTP information even if I upload a zip file. Something’s not right here.

    siggma…. changing ownership worked like a champ! thanks

    I went back and changed the permissions on the entire wordpress directory and things are working now. I’ve got to admit, this doesn’t feel very secure to me. Does anyone know what actually needs to be writable by www-data?

    This article may be helpful in explaining what files need permissions changed:

    Thanks, Just supply your FTP account that can overwrite and/or modify the plug-ins files, basically the same FTP information to your site. CHMOD -R 777 all files isn’t exactly very secure, especially on shared hosting.


    I am using Debian as well, and chown -R www-data:www-data /var/www works like a charm.

    I didn’t even change the file permissions.

    I did change file permissions to 0777 and used “chown -R www-data:www-data /var/www” but what I got is an error message: “500?”

    My wordpress is installed on the site root folder (www/).

    @siggma Nice one, thanks! Hadn’t noticed some of my directory ownerships were wonky. Fixed it for me.



    1. Check under which users is running your http server
    [root@rippervp pro-soccer]# ps aux | grep -i http
    apache 1898 0.3 5.5 306092 43732 ? S 10:13 0:04 /usr/sbin/httpd
    Im my case httpd is running under username apache
    2. Change ownership of your wordpress directory
    chown -R apache:apache public_html/

    I’m using centos 5

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘WordPress/plugin upgrade’ is closed to new replies.