Support » Networking WordPress » WordPressMU: Posts links lead to 404 error

  • Hello, all. I’m trying to set up Multisite with subdomains. The install goes fine and I’m able to enable the network (and Multisite also.)

    I can create new sites and can create entries for those sites. New posts show up on the blog’s front page, but when I go to click on the actual blog’s post link, I get a 404 error.

    Is this an Apache, dns, or some other issue? Is there more information that you guys would like me to provide to help you help me?

    Thanks for reading.

Viewing 15 replies - 1 through 15 (of 15 total)
  • http://www.nelsonshack.com is the site in question, btw.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    What’s your .htaccess?

    Thanks for the response, Ipstenu. Here it is:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    What happens if you turn off pretty permalinks?

    (That’s the correct htaccess for a subdomain install – Are you using that or subfolders?)

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    It’s Apache and mod_rewrite issues.

    Individual post links don’t even work on your main site either. Did you put in the .htaccess file? Does the server have mod_rewrite enabled?

    I have this in my httpd.conf:

    LoadModule rewrite_module libexec/apache22/mod_rewrite.so

    I put the .htaccess file in my /usr/local/www/apache22/data (documentroot)

    I’m using subdomains for this install.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    But by default apache sets up each vhost to have mod_rewrite disallowed. 😉 Gotta turn it on.

    Per this page,, I now have this in my nelsonshack.com v-host conf:

    <VirtualHost *:80>
        ServerAdmin nathan@nelsonshack.com
        DocumentRoot "/usr/local/www/apache22/data"
        Servername www.nelsonshack.com
        ServerAlias nelsonshack.com *.nelsonshack.com
        RewriteEngine On
        RewriteOptions Inherit
    </VirtualHost>

    Is that the correct way to enable mod_rewrite for each v-host?

    Well, I’ll be, ipstenu, you were right. Turned off permalinks and now it works. Thanks, buddy. Props.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    If it works sans permalinks then, as Andrea said, your .htaccess file isn’t being read 🙂

    The problem is that without that working, MultiSite becomes a pile of steaming poo.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Yeah, try logging in to the admin areas of the sub sites. :-/ bet they won’t work.

    Is that the correct way to enable mod_rewrite for each v-host?

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    
    AllowOverride FileInfo Options

    further reading

    http://is.gd/jczEO5 and htaccess http://is.gd/MGChRL

    Well, actually I can get to http://bloodytoe.nelsonshack.com/wp-admin and log in and make changes, see posts, etc. Should I still go down the mod_rewrite route?

    Thanks, again.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Huh.

    http://nelsonshack.com/ and http://bloodytoe.nelsonshack.com/ have the exact same posts. Is that intentional?

    Ah…sorry. Yeah, Nelsonshack.com pulls in a few blogs through RSS. So ignore http://www.nelsonshack.com. Forgot to explain that.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Okay 🙂 Just wondering if that was indicative of the problem or not 😉

    Yes, I would still go down the mod_rewrite route. Also check into your allowoverride settings.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘WordPressMU: Posts links lead to 404 error’ is closed to new replies.