WordPress.org

Forums

WordPress.com Forums » Support Move WordPress blog to private domain (19 posts)

  1. HeidiGarm
    Member
    Posted 2 years ago #

    Hi,
    I am trying to move my wordpress hosted on wordpress.com to my own hosted private domain (not WordPress.org).

    I have done Tool- export, but when doing import on my private domain, I get this error message:

    "Server error!
    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.
    If you think this is a server error, please contact the webmaster.
    Error 500."

    I can see in bottom on my export file, following message:
    "The operation completed successfully. Error processing resource 'file:///C:/Users/eheigar/AppData/Local/Microsoft/Windows/T..."

    Do you know why I get this error message?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    That sounds like an error in your export file.

  3. HeidiGarm
    Member
    Posted 2 years ago #

    ok, but do you know what I need to do?

    I have tried to read on this forum on other with this error message, and they say changes need to be done on a file called httpd.conf, it should be located in XAMPPInstallDirectory\apache\conf\

    "Open with notepad and find this line
    #LoadModule rewrite_module modules/mod_rewrite.so
    Remove the #, save it, restart apache (if running)."

    But I don't have access to this file.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Is this new site locally hosted or are you using a remote hosting company?

  5. HeidiGarm
    Member
    Posted 2 years ago #

    This new site is a local hosting.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Does the error reference the .xml file? It would be helpful if we could see the full error message.

  7. HeidiGarm
    Member
    Posted 2 years ago #

    First I do export of all content, and the file is very small, which I also think is strange since I have 500 MB with pitures.

    I go to my private new site, and do Import WordPress, I fetch my .xml file and also use the option "Download and import file attachments", and after some minutes I get this error message:

    Server error!

    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

    If you think this is a server error, please contact the webmaster.
    Error 500
    http://www.garm.no
    Mon Jul 30 14:02:50 2012
    Apache

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    The exported .xml file will only contain your content text and the image urls. All of the images themselves will be downloaded via their urls as part of the import process. So the .xml file will be relatively small.
    What about this error?

    Error processing resource 'file:///C:/Users/eheigar/AppData/Local/Microsoft/Windows/T..

    Can we see the full error message please?

  9. HeidiGarm
    Member
    Posted 2 years ago #

    I did now do the export from my Mac instead of windows PC, and then the files seems to work, no error message and it seems to have fetched everything in the exported .xml, but I get the same error message when I do import on the new site.

    This means that it can't be the export file that is wrong, isn't that correct?

  10. HeidiGarm
    Member
    Posted 2 years ago #

    I do log in as admin when I do import, or should I use another user?

  11. esmi
    Forum Moderator
    Posted 2 years ago #

    Can we see the full error message please?

  12. HeidiGarm
    Member
    Posted 2 years ago #

    You have already seen the error message. it is nothing new.
    I don't get any error message in the .xml export file since I am using Mac laptop, only when importing the file, I still get this error message:

    Server error!

    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

    If you think this is a server error, please contact the webmaster.
    Error 500
    http://www.garm.no
    Mon Jul 30 14:02:50 2012
    Apache

  13. HeidiGarm
    Member
    Posted 2 years ago #

    Could it be something on the sql server or wrong user credentials on the sql server or FTP servers??

  14. esmi
    Forum Moderator
    Posted 2 years ago #

    Error processing resource 'file:///C:/Users/eheigar/AppData/Local/Microsoft/Windows/T...

    That error message.

  15. HeidiGarm
    Member
    Posted 2 years ago #

    But as I said earlier is that I don't get that error message when I do export by my Mac laptop. This error message is only on my windowslaptop and that could be because of using Windows Vista.

    So this error message is not relevant anymore since I don't get it on the Apple Mac laptop. But I still get the other error message when I don import of this correct file.

  16. HeidiGarm
    Member
    Posted 2 years ago #

    I have now tried to export file from both Windows 7 and Apple Mac OSX lion, and the file looks correct. So the error message I receive from Windows Vista PC, has something to do with the old client.
    So I tried to import by using both Windows 7 PC and Apple Mac laptop and I still get the erromessage Server Error...
    So it can't be the export file that is wrong.

    There must be some limitation for me to import the file.
    Are your agreed?

  17. esmi
    Forum Moderator
    Posted 2 years ago #

    How large is the file?

  18. HeidiGarm
    Member
    Posted 2 years ago #

    I finally found out how to import the file to avoid the error message :-)

    I have logged on to the FTP server and can see that several images has been uploaded to the new site. On the site no content was visible.

    I tried to do a new import, but now without the “Import Attachments” option. Now I can see all my blog posts, but some pictures are missing. All my pictures on all added pages is missing, but there are a lot of pictures on the FTP site. Do you know how I can fetch these pictures?

    In addition I am using Elegant Grunge theme, but it seems that it is not available anymore. Could I hack something so I can use this theme?

  19. HeidiGarm
    Member
    Posted 2 years ago #

    I found out about this:
    To be able to import all content to the new wordpress local hosted site I had to do the import several times. After one import approximately 3-10 new pictures were imported. So it is only to be patient and do an import many many times and everything will come over to the new site eventually. If I take a look under library I will see that the number of pictures increases.

Topic Closed

This topic has been closed to new replies.

About this Topic