Support » Installing WordPress » WordPress, Xampp, and Virtual Hosts "Error: PHP is not running"

  • Resolved Suicidolt


    I’ve never set up wordpress before. Never really knew what it was until now. I host the server myself, so I’m have full access to any changes that need to be made to it. This seems to be the first problem, as almost all of the “help” I have found is for people arguing with their webhost.

    In any case, my problem appears common but I can’t find anything on it, with every faq and google I can think of. I have set up wordpress both through the config file, and by clicking on the link, and no matter what I do I keep running into “Error: Php is not running.” Of course, php is running, as I am also hosting a phpbb forum on this server (and on the same virtual host as it turns out. I edited phpmyadmin to set up the proper databases, and modified the config file, even gave wordpress its own username and still it tells me php is not running. I even placed a test file to run phpinfo() in the wordpress folder I created and that works fine. So wordpress is not finding my php. Moreover, it’s going past the “if” that checks for php and calling a number of other functions in the install.php file. When I open the page, the screen is full of incomplete php crap that makes no sense.

    I have reached my limits as I’ve been fiddling with this the whole day just to set up a blog (that’s actually how I found wordpress, via a theme that I liked) and I am asking for help. The website is a Kissimmee D&D and Neverwinter Nights Server. The wordpress is in the /wordpress directory, and if you do /wordpress/phpinfo.php you’ll see the php info.

Viewing 11 replies - 1 through 11 (of 11 total)
  • wow, have I confused the entire wordpress community?

    resolved thanks to help from users on IRC

    I have a similer problem and would appreciate how it was resolved.
    This is my first attempt to install the latest edition of wordpress 3.0
    and follewed the instructions to the letter

    Downloaded all the wordpress 3.0 files
    Created the msql database
    Uploaded all the wordpress 3.0 files to the root directory
    Edited the config.php file to include the data base info

    So far so good. Until I hit the the wp-admin/install.php
    Received the following error message

    ” >>> PHP is not running
    WordPress requires that your web server is running PHP.
    Your server does not have PHP installed, or PHP is turned off<<<<“

    I know my hostserver has PHP Installed and running because
    I already have two other wordpress.2.92 blogs on the same server

    Any assistance would be appreciated to prevent this old man following this piece of technical equipment out of the window.




    frontdesk500 – did you ever get your issue resolved? Of course, I have the same issue and can’t find an answer. I see the question asked several times although no one has responded (at least from what I’ve seen).



    I would appreciate help with this problem also please…

    What I did to overcome the error: PHP is not running problem.
    Open xampp control, switch on apache and MySQL
    Open xampp Apache admin,
    Open your wordpress database (tools/phpmyadmin or whatever)or create a new one.
    Select priviledges (second last button across the ‘tables’ and create new user with global priviledges on that database.
    Either select no password, select ‘localhost’; or enter a password of your choice, press ‘GO’, to save, check the changes have been saved.
    Edit wp-config.php and update the settings for user, password.
    In your browser enter http://localhost/wordpress/wp-admin/install.php and enter the same details again.
    I am no expert in this but thats how I got it to go. The issue was in getting WordPress and the database to talk to one another.
    Hope it works!

    I used MAMP as a local host. I had to edit its Preferences and change the “Start Page URL” to “/” insead of “/MAMP/” for it to stop giving me that error.

    When installing WordPress locally, i.e., via xampp, etc., you CANNOT simply just open your web browser and file open to the install.php file. If you do you’ll get the “Error: PHP is not running” message. What you need to do is run the file locally, i.e., type “http://localhost/path-to-install-file” replacing the correct path to the install.php file in the URL. If your database permissions are correct for the user listed in your wp-config.php file, as well as the password, and of course the DB_HOST is set to ‘localhost’, then the page will render properly. can replace ‘localhost’ if so desired.

    I hope this helps those trying to do a local install. It’s pretty common to just file open to a particular file on our computer and expect it to render. But in this instance, your computer is acting like a server and you must tell it where to go but do so as if it were a proper http:// URL (as opposed to file://) which will then activate the usage of the php and mysql applications behind xampp or whichever virtual host you are using.

    I think in a situation like this it’s just best to move on. I installed CMS made simple without a hitch. Just not too pleased with the program. I just want to install this program not send a space craft to Mars so it appears the search will continue.

    parajuris, Thank you! I wasn’t sure if this is what I had to do because WP makes it seem like the “5 minute install” is stupid simple and error free but your instructions worked.

    it sounds like i have the same prob as others here. after upgrading phpmyadmin to 5.0, and upgrading wordpress to 3.2, EVERYTHING was gone. all posts, pages, categories, theme, theme options, everything. restored database twice, one was from a backup on my hard drive. no luck. hosting is at godaddy. OS is linux. database is sql, which i’ve read is a mismatch, but it was fine until i upgraded php and wordpress.
    having trouble interpreting some of the fixes, i don’t speak wordpress, linux, php etc very well.
    if anyone can explain how to fix the breakdown between wordpress and database in dumbed down terms for me, i’d appreciate it.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WordPress, Xampp, and Virtual Hosts "Error: PHP is not running"’ is closed to new replies.