Support » Plugin: Akismet » WordPress Wysiwyg Editor Problem

  • After I upgraded my WordPress site to version 3.9 I noticed that my Wysiwyg Editor stopped working. I already have this fix in place in my wp-config file:

    define('CONCATENATE_SCRIPTS', false);

    So I disabled my plug-ins one by one and found the issue to be with Akismet Version 3.0.0. I am not sure if anyone else has had this issue? For now I have Akismet disabled.

    https://wordpress.org/plugins/akismet/

Viewing 9 replies - 1 through 9 (of 9 total)
  • The same for me. Had troubles (aparently) with javascript in the WYSIWYG editor, after upgraded WP to 3.9. “Solved” when disabled Akismet. One detail: it doesn’t happened in my local copy.

    esmi

    (@esmi)

    Forum Moderator

    The issue is not in Akismet. Can you replicate the problem using the default Twenty Fourteen theme with all other plugins deactivated?

    I did disable each plugin that I had and Akismet was the one causing the issue. The theme I am using is the Fourteen Theme. For now I have Akismet disabled. Let me know when this is resolved.

    Plugin Author Christopher Finke

    (@cfinke)

    It’s possible that this was caused by the way that Akismet uses some JavaScript in version 3.0; that method was changed a couple of weeks ago (https://plugins.trac.wordpress.org/changeset/907986/akismet/trunk) and the fix will be included in 3.0.1 (or whatever the next version number).

    vletroye

    (@vletroye)

    Hello. I have quite a similar issue when I edit posts. Features from the Visual Editor, assumed to open a floating pane, like “Add Media” or “Insert/Edit Link” are not working anymore when Akismet is enabled. Others, like “Bold” or “Indent” still work fine.

    I have this issue with Chrome and IE (both up-to-date)

    I tried to clean my cache after switching from my theme to Twenty Fourteen, but it didn’t some solve my issue. I tried also to upgrade Akismet from 3.0.0. to 3.0.1 but without more success 🙁
    I also defined CONCATENATE_SCRIPTS = False as suggested but it didn’t help.
    I have tried to add “define(‘SCRIPT_DEBUG’, true);” but it didn’t solve anything either.

    I am running WP 3.8.2, the latest version packaged by Synology for my NAS.

    I couldn’t survive without Akismet! So, I don’t keep it disabled. But it’s really frustrating.

    vletroye

    (@vletroye)

    I found that everything works fine if I rollback to Akismet 2.5.9 (I don’t have the version 2.6.0 to give it a try)

    I also found that installing “Use Goole Libraries” results in the same issue (floating panes don’t open anymore).

    So, IMO, the problem is related to a new version of some ajax/jquery features… possibly within jquery-ui.min.js as looking into my browser’s developer console, I see errors for that file: Uncaught TypeError: undefined is not a function

    So, I won’t upgrade Akismet and wait for a new Synology’s package with a more recent WP.

    skylermoon

    (@skylermoon)

    So FYI I had this same problem, disabled, and re-enabled and it worked just fine.. Others reporting the problem too.

    jankph

    (@jankph)

    I’m using Atahualpa 3.7.15, WP 3.9.1 and Akismet 3.01. Akismet disables the Add Media button when writing or editing posts. It also disables the quick lookup for tags when I try to enter the first letters in a tag I want to add. I’ve checked by disabling all plugins and adding one-by-one. Only Akismet gives me that error.

    vletroye

    (@vletroye)

    I also experienced this issue you have with the tags.

    Disabling and re-enabling akismet did not the trick.

    Only solution I found, after hours of investigation of the code, was to rollback to a version 2.x of Akismet.

    It’s interesting to read that upgrading to WP 3.9.x wouldn’t solve my issue…

    V.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WordPress Wysiwyg Editor Problem’ is closed to new replies.