Support » Plugin: WP PGP Encrypted Emails » wordpress->wpadmin not encrypted

  • Resolved bugrider

    (@bugrider)


    WordPress 5.4.1
    Theme: Twenty Twenty 1.4
    Plugin: WP PGP Encrypted Emails 0.7.4
    Users: wpadmin is the only user defined on this site

    In WordPress:
    Settings -> General -> Administration Email Address
    is identical to
    Users -> wpadmin -> Email

    Setting -> Email Encryption -> Admin Email PGP Public Key
    holds the PGP public key for the email address in
    Users -> wpadmin -> Email

    Users -> wpadmin -> Email Encryption -> Your PGP Public Key
    holds the same PGP public key

    Then testing it:
    a)
    Users -> wpadmin -> Send me a test email
    results in an email sent to the email address defined for wpadmin. This email is PGP-signed but NOT PGP-encrypted.

    b)
    Logout -> Lost your password? -> wpadmin -> Get New Password
    results in an email sent to the email address defined for wpadmin. This email is PGP-signed but NOT PGP-encrypted.

    Problem:
    I assumed that these emails would have been PGP-encrypted with the above stated setup. They are not. What is the error in my setup?

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m sorry to ask but have you found a solution? I seem to have a similar problem.

    WordPress 5.5
    php: 7.4.
    Theme: GT Basic
    Plugin: WP PGP Encrypted Emails 0.7.4
    Users: wpadmin is the only user defined on this site

    I included my public key into my profile as well as in the field for the admins public key in the plugin settings itself. Sending a test mail from the profile setting site leads to a pgp signed but not encrypted mail. Content of Contact forms sent to the wpadmin address arrive as well signed but not encrypted.

    Since it can sign mails the plugin seems to be able to use its “own” private pgp key but give the fact that it does not encrypt the mails … the problem seems to be somewhere there… did I miss anything? I sorry that I bother you but I havn’t found a solution in the questions asked in this forum.

    Thread Starter bugrider

    (@bugrider)

    I have not found any solution.
    Hope that the author of this plugin will make a statement.

    Plugin Author Meitar

    (@meitar)

    I assumed that these emails would have been PGP-encrypted with the above stated setup. They are not. What is the error in my setup?

    Sorry, I cannot reproduce this issue. With the above settings, emails are getting encrypted on my test environments. As many other threads here advise, you should follow the standard plugin troubleshooting advice to help isolate the problem.

    I have a similar problem as decribed in post 1.
    Outgouing emails are pgp signed but not PGP-encrypted.
    Same pgp public key (and email adress) in plugin settings and profile settings.
    Using with CF7.
    Any solution yet?

    Plugin Contributor maymay

    (@maymay)

    .

    Plugin Author Meitar

    (@meitar)

    Since the issue cannot be reproduced, the solution is almost certainly one only you can provide for yourself. The FAQ entitled “Why are emails from [other-plugin-here] not being encrypted?” shipped with this plugin may be helpful.

    @meitar If sender adress (have pgp public key entered) is same as receiver, email are encrypted. Send to other receivers emails are just signed. Why?

    Plugin Author Meitar

    (@meitar)

    The only emails that are encrypted are the ones for which a public key is available. Your questions tell me that you do not understand the intended purpose or operation of this plugin, that the issue is not the code but the user, and that the amount of documentation present on this forum and in the plugin’s own README, FAQ, and other resources are insufficient for you. Given this, there is nothing more I can or will do to help you. Good luck.

    Ok @meitar maybe I really don’t understand how it works plugin. before I asked the question i chech the documentation and forum.
    I will be grateful if you explain/help me, why only admin email and one user that have same email as admin receive encryped email. I create other user with other email(same domain), insert public key. Try to send test email, they come just signet but not encrypted.
    What i do wrong?

    Recreate user -> insert public key. Now works. Thanks a lot!

    Plugin Contributor maymay

    (@maymay)

    .

    Plugin Author Meitar

    (@meitar)

    Recreate user -> insert public key. Now works. Thanks a lot!

    Congrats. Glad to hear you figured it out and got it working. 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘wordpress->wpadmin not encrypted’ is closed to new replies.