[resolved] WordPress working on shared-hosting but not VPS (4 posts)

  1. artcoder
    Posted 5 years ago #

    I migrated a WP site from shared-hosting to VPS hosting. On VPS, I'm able to connect to database and see pages of site fine. But when I go into WP-admin, I see ....

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 92160 bytes) in /var/www/vhosts/stanfield.com/httpdocs/wp-includes/class-simplepie.php on line 2479

    in the "incoming links" panel.

    And when I click on the "Pages" menu in Firefox, it pops up a prompt saying do I want to download the file something.php.

    Other menu item is okay, and other are not.

    What is going on? It was the exact same code that was on the shared hosting. Is this a wordpress problem or a server problem?

    Please help.

  2. James Huff
    Support Representative
    Posted 5 years ago #

    More than likely, PHP's memory limit was set higher on your shared server.

    Edit your php.ini file to increase the memory limit. For example, memory_limit = 64M

  3. artcoder
    Posted 5 years ago #

    I've tried that. Did that in php.ini and php5.ini. No luck. :(

    Is there some server setting I need to make via Plesk or Virtuosso interface in regards to setting memory on a VPS server?

  4. James Huff
    Support Representative
    Posted 5 years ago #

    Since you should have full control over your VPS, it stands to reason that editing php.ini should be enough to alter the PHP configuration. I guess you'll have to contact your hosting provider.

Topic Closed

This topic has been closed to new replies.

About this Topic