WordPress.org

Forums

WordPress with buddypress and MU giving error for new blogs. (26 posts)

  1. jamesg371
    Member
    Posted 4 years ago #

    Hello everyone. I have been using wordpress for a while and i am fairly competent with it, however i am now working with a buddypress mu installation and I have had some issue with it and was wondering if anyone here could help me to figure out this issue that I am having. The problem is that when a new person registers for the site, they can not access their blog. I do have blog farm option set up in the Mu settings and everything seems to be setup properly following the codex and manuals with buddypress and mu that I have been able to find. When my subscribers go to their blog and even when I go to their blog all we get is an error in the top left of the screen that reads "Template Error: The template file must be given". In the admin tab I do have 4 themes activated and ready for use. Has anyone had this issue before and how did you fix it? Or, better yet, does someone here know why this would be happening and how to make it stop? I did put a directory in my server called blogs - Was I supposed to name it blogs.dir or how does that work? alos, am i supposed to move templates somewhere in the server for use with the blogs? Anyways, can anyone help me?? Thanks, james.

  2. Did you remove the twentyten theme?

    New blogs, by default, set that theme as the theme. If you remove it, you break that.

  3. jamesg371
    Member
    Posted 4 years ago #

    Hey, thansk for the reply. No i did not touch the twenty ten theme. I do have it activated in the super admin themes options as well. Should I lay a new copy of the twenty ten theme into the wp-content/themes folder? Also, when they say make a folder and name it blogs.dir do they literally mean name it with the .dir at the end of it? I would think that the server will do this automatically wouldnt it? Kind of like an extension when you save an image file? Maybe, lol.

  4. "Template Error: The template file must be given"

    Thats not a WordPress or a BuddyPress error. Are you using subdomains?

  5. Also, when they say make a folder and name it blogs.dir do they literally mean name it with the .dir at the end of it?

    Yes, but this has nothing to do with why your blogs do not work

    they are *virtual* There will be no folder on the server where they live.

  6. jamesg371
    Member
    Posted 4 years ago #

    yes I am using sub domains and I have setup my wildcard in my WHM panel to look like this " *.mysite.com 14440 A " and so on. I have made sure that my htaccess file and my phpini.file are both wrote the way that the install says to wirte them. I mean to say that I copied and pasted the lines of code into it. Im not sure what to do next.

  7. jamesg371
    Member
    Posted 4 years ago #

    ps here is my wildcard setup copied from that domains cpanel.
    *.mysite.com. 14400 IN A ip.add.res.s94 changed ip numbers to letters just in case, llol

  8. If you're using WHM, then odds are your mysite.com has a cPanel component, right?

    It's easiest, in cPanel, to add wildcard subdomains inside the cPanel subdomain registration, rather than WHM itself. I would undo the WHM stuff and just do it in channel to start with.

  9. jamesg371
    Member
    Posted 4 years ago #

    Well, i went in and took the wildcard dns from my whm panel and then went into my cpanel and set it up under the sub domains and sure enouhg it populated under the dns tabels in cpanel. thansk for that tip, however, I still have the error when trying to access any of the blog farm blogs created by new users and they can not acces them either. Any ideas?

  10. Did you even google that error after I mentioned it's NOT WordPress? First hit:

    If you are getting the above  error while accessing your  site , it  means your  domain  entry  is missing in the “Apache  ConfigurationFile”
    (httpd.conf) .

  11. jamesg371
    Member
    Posted 4 years ago #

    I have googled this up and down and have not found that anywhere. Hmmm. Ok so I do not think that i have acces to the apache handler or the config file. If i do, then im not sure where it is or how to access it, lol. ugh - sorry for being lame.

  12. jamesg371
    Member
    Posted 4 years ago #

    Oh, yes I did see that one a few days ago, im sorry, but when i ftp'd to my server and went thru every folder and file outside of my public_html folder i could not find one by that name anywhere. Is this a file I have to edit from whm oer cpanel?

  13. It's a file in Apache. Which means if you do not have ssh access, then no - you can't reach it.

    Its location depends on the OS on the box.

  14. jamesg371
    Member
    Posted 4 years ago #

    i donty think that I have shell access, would my hosrt provider do this for me?

  15. Go ask your support at your webhost how to enable wildcard subdomains.

  16. jamesg371
    Member
    Posted 4 years ago #

    Hi Andrea, I have that part down pat, lol. I do belive that adding my doamin to the apache file is the key here. It is in the mu setup instructions for the setup and I do not have ssh or shell accees becauser i run a small rag tag hosting company that i built up off of just host servers. So I am lijmited ther, but I did actually send an email to the host guys and asked them about it - I dont think they mind this kind of thing but i do belive that i will have to tell them exactly wehat to put in there and all. Anyways, thansk for the input Andrea, every word I read is invaluabble to me and the Process, lol. Thanks

  17. jamesg371
    Member
    Posted 4 years ago #

    oh, please excuse my spelling, I actually know how to and I know spell check too, lol. I am working on like 3 projects, answering emails, on the phone and chatting on skype with clients and contratcors so im just flying thru typing right now. sorry

  18. It's very odd to have access to WHM and not to have ssh access to the rest of things.

  19. jamesg371
    Member
    Posted 4 years ago #

    I have a reseller account. :( and not a dedicated Ip reseller account - yet.

  20. I have a VPS with a reseller account. If you have WHM access, you really should have ssh and root access. I'm just saying its weird. Most hosts I've met allow it.

  21. jamesg371
    Member
    Posted 4 years ago #

    Also, all of a sudden the blog sites just started working. I did go in and wipe out the dns rule in my whm and then i redid it as a sub-domain per your gracious enlightenment, ( thanks for that) and went back and they all work. Now heres then enxt problem. on first look - all of the sites appear as blank white pages. If I login into the dashboard using the /wp-admin and login from there it does take me to the dashboard and then I have to manually choose a template or theme. and then it works fine, like a site inside my site,lol. How can I force a default template or theme?

  22. jamesg371
    Member
    Posted 4 years ago #

    if you dont mind, who is your provider?

  23. jamesg371
    Member
    Posted 4 years ago #

    Well, ( sigh) sadly I was wrong. Somehow it did seem to all work properly for a short time. All I did was close out my cpanel and some other windows and then they all went back to saying the template error again. lol. Ugh, this is frustrating, lol.

  24. jamesg371
    Member
    Posted 4 years ago #

    here is something really wierd. if I log into the system using a free account or a members account I can readily see and work in the blogs that mu creates. However, I can not see or access any of them if iam logged in as admin to the main site. I get the template error. this seems like a big clue, does anyone have any ideas?

  25. At this point, it's gotta be something screwed up on your host. Ask them for help. If they can't, i would shop around for a new host.

    And we're asked not to pimp our preferred hosts, so ... Can't :/

Topic Closed

This topic has been closed to new replies.

About this Topic