WordPress.org

Support

Support » How-To and Troubleshooting » WordPress widgets not working

WordPress widgets not working

  • I am not able to drag the widgets to sidebar in my wordpress blog. The wordpress version is 2.8.
    I just upgraded the wordpress version yesterday.
    Is there anything wrong with the upgrade? Please give give me an answer. Thanks in advance.

Viewing 15 replies - 1 through 15 (of 25 total)
  • mine aren’t either – I just did the new update about 5 mins ago..

    Robyn

    in fact I have the tiny miced advanced and it’s not even their evan when I updated the widget. also when I go to do a post my image doesn’t show in my post only the html.. this version is so totally different.. is their a fix for all of this? I sure hope so

    Thanks
    Robyn

    blog

    I just read all the fixes for this .. I uninstalled all my plugins, deleted the cache and it still don’t work.. especially the tiny mce plugin.. not there.. help please someone!!

    esmi
    Forum Moderator

    @esmi

    Try deactivating all plugins and check to see if this resolves the problem. If it does, the chances are that 1 or more of your plugins is currently incompatible with WP 2.8 and you’ll need to wait for a plugin upgrade before using that plugin again.

    my post above states that I had uninstalled/deactivated my plugins.. and nothing got resolved!

    esmi
    Forum Moderator

    @esmi

    In Appearance->Widgets under Screen options, try the Enable Accessibility Mode.

    yes i’ve tried there also.. Now my new links are not working either.. I’ve been messing with the blog all day with no results and I’m quite frustrated. This morning my blog was working fine and then I update and I have nothing! this is an update? wow could have fooled me! I have a copy of my old blog can someone tell me how to put that back in please.. I will never do another update.. I have read all the other people having the same problems (there are quite a few) and noone can really give them a fix. just try this and try that.. once again it is for the people who are totally versed in changing their own codes.. who know css and php.. I think it is quite unfair the people like me who have bothered to learn the very basics of changing and redoing codes have to deal with this now.. yes I’m mad.. you people have worked very hard for a quality blog that I have been with for awhile never bothering you with questions always learning how to do it myself but this is too much! This time it is way over my head and many others it seems.. once again please someone tell me how to go back to my old version that I saved when doing the update..

    Thank you
    Robyn

    I guess noone is going to answer me because I spoke my mind.. sorry but it is extremely frustrating not having the blog and I’m losing money in my shop because of it. would you not get frustrated too?

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    Try installing the “Use Google Libraries” plugin. See if that fixes it.

    If that works, then you’re having javascript compression issues. The plugin (among other things) disables that piece of 2.8.

    The new release of 2.8.1 will have some changes to correct the compression problems, for people who have the issue (it’s relatively rare, only happens with certain servers and browsers, etc).

    On a side note, if an upgrade is going to make you “lose money”, then I would recommend TESTING before installing new software first. Any shop that depends on a piece of software needs to have some form of quality control in place. WordPress is free software, no warranty. If it breaks, then that is your problem.

    So next time, have a test site up and running to upgrade and test first, before you upgrade your main “money-making” system, yeah?

    yes that is a good idea about a test site.. I have done so many upgrades in the past year and never ever had problems like this so I never thought of that.. I do not have the use google libraries plugin installed.. my main thing is that tiny mce is not working at all, and most of my widget even though I have uninstalled all of them and one by one put them back on will not work.. If someone can just tell me how to get my backup onto my ftp so I can go back to where I was before the update I would be grateful..

    Thanks

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    I do not have the use google libraries plugin installed.

    Yes, try installing it and see if the problems go away.

    Stevorino
    Member

    @stevorino

    Temporarily until the problem is fixed you can click on “screen options” and then click enable accessibility mode. Now you will be able to add widgets. Inconvenient but it works.

    fusionpowered
    Member

    @fusionpowered

    is there any theme related code in your functions.php file? I found that if I had a space in the widget name that it wouldn’t work (only when ‘name’ is a single string arg).

    alajoann
    Participant

    @alajoann

    Thank you, Stevorino! Enabling accessibility mode in screen options allows widgets to be moved and used as intended. (Not so inconvenient when compared to other solutions suggested!)

    CrazySerb
    Participant

    @crazyserb

    Nope, using Google Libaries plugin didn’t help.

    Nope, disabling all plugins didn’t help.

    Nope, clearing out browser cache didn’t help.

    And no, accessibility mode doesn’t cut it as it takes 3-4 clicks to do what drag & drop used to do.

    Any other ideas?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘WordPress widgets not working’ is closed to new replies.