Support » Fixing WordPress » WordPress Widget Filters Do Not Work

  • computersfryyourbrain

    (@computersfryyourbrain)


    I am trying to make a widget that consists of the Filters for attribute, price, and Rating. None of them are returning any results. I go to my shop page and select a sidebar, I select the sidebar that I put those widgets into, and I get nothing but an empty box.

    I have tried googling and I see a lot of old posts where people had the same issue but nothing seems to fix it.

    I have items, I have attributes set, prices, etc…. So what gives? I am going crazy.

    And what’s up with the new WordPress widgets design. it’s terrible compared to the last one.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Which plugin are you trying to use? Also, try installing the plugin “classic widgets” to get back a sensible way to put widgets on a page.

    Thread Starter computersfryyourbrain

    (@computersfryyourbrain)

    Hi Steve,

    No plugin. I use elementor when building. i actually just found this link https://developer.woocommerce.com/2021/08/12/brace-yourselves-new-product-filtering-by-attributes-is-coming/ that seems to mention the issue. It seems like they know there is an issue and aren’t able to fix it. They have come up with some kind of workaround it seems but I am not comfortable enough to start doing what they suggest.

    Hopefully they fix it sooner than later. that article is from August so it has already been some time.

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    I don’t use elementor, so I can’t advise on that at all. When I’ve needed to do filtering for a Woo site, i’ve used WOOF.

    Thread Starter computersfryyourbrain

    (@computersfryyourbrain)

    I have tried several different themes now and disabled all plugins. Still not working. After searching forums, I see this has been an ongoing issue for years so I am not sure why it hasn’t been resolved but it is pretty ridiculous that a plugin designed for e-commerce doesn’t have functioning filters.

    I suppose the last thing to do is find a plugin to fix the plugin… which you shouldn’t have to do.

    fuming

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.