Support » Fixing WordPress » WordPress wants FTP details for everything, installing plugins/themes, importing

  • I recently decided to add my wordpress blog to my domain, rather than having it separate on I downloaded and installed 3.5.1, and installed it (I use CoreFTP for FTP access, and phpmyadmin for my database. LAMP stack server, Rackspace Cloud Server). The installation worked fine, and I’ve been able to log into the blog…but any attempt to install a plugin or theme, or import anything (like my posts from the blog) get a request for FTP details, and no combination of possible hostnames, usernames, and passwords has worked.

    This appears to be a fairly common problem, and I’ve spent hours and hours on this, but every solution I’ve tried has failed. A lot of places suggest changing the wp-config.php file to include something like:

    define( ‘FTP_USER’, ‘username’ );
    define( ‘FTP_PASS’, ‘password’ );
    define( ‘FTP_HOST’, ‘’ );

    That didn’t work (nor did a variety of similar fixes that had other things to define). I tried changing the permissions via FTP, even going so far as to make most of the blog 777, and even still that didn’t seem to work (I’ve since changed it back).

    I got around this for a bit by manually adding plugins and themes by FTP, but that solution still doesn’t let me do things like upload media, and some of the plugins don’t work properly (for instance one to create a sitemap cannot do so).

    One possibility I’ve seen raised elsewhere is that something is happening where the owner of the files is apache:apache (or something like that), which is not the user I use on CoreFTP, but I haven’t seen an explanation on whether that’s a solvable problem or not.

    Any help on solving this issue would be most appreciated!

    EDIT: Also worth mentioning:
    I tried this solution, and it got the closest (seemingly) to working, but also failed. I added the following code to wp-config:


    This got me past the FTP request, but when trying to install a plugin (for example), I get: Downloading install package from plugin)

    Unpacking the packageā€¦

    Could not create directory. /(my site stuff)/www/blog/wp-content/upgrade/(example plugin).tmp

    Even combining the above code change and changing permissions on all the wordpress folders to 775 didn’t work.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You need to contact your host as it looks like a server specific problem. Review:

    I think you may have included the wrong link (unless I’m missing the connection to brute force attacks and the issues I’m having).

    I included the links just because the problem described by you generally occurs when the server is configured to disallow certain actions. BTW, did you contact your host?

    If it is a problem with your FTP credentials, you may get them from your hosting account. If they are not already set, you can create your FTP password and other credentials.

    It’s not a problem with the FTP credentials; I work on the code pretty close to daily, so I know my FTP credentials are correct! I’ve also spoken to my webmaster/fellow who originally set up our server about it (the server is a Rackspace cloud server, so I’m not sure this is something that Rackspace has any control over) and he took a crack at it by “[adding] the sftp to the same user group that owns the wp-content folder, and then set the folder to 775 so that group has write access”, but that didn’t solve the issue either.

    EDIT: I guess I might as well call Rackspace, just to see if there’s anything they can do about it.

    Did Rackspace help you?

    The FS_METHOD is suitable, if the web server is allowed to make any change. This is not recommended in general for security reasons.

    Inserting FTP credentials is the recommended method. But that works only, if the credentials are accepted, when asked, while installing a plugin or theme.

    We’re going to try using a different FTP method to see if that solves the problem. I’m waiting for my webmaster to install it, and then we’ll see if that works or not, but it was the only solution Rackspace had.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WordPress wants FTP details for everything, installing plugins/themes, importing’ is closed to new replies.