Support » Fixing WordPress » WordPress upgrade from 4.1 to 4.1.1 – blank screen

  • Resolved Sony Merlin

    (@sony-merlin)


    Our website is currently in WordPress 4.1 and I tried updating it to WordPress 4.1.1.

    After entering the FTP username and password the page becomes blank. The top and left menus of the dashboard are displayed, but the content area is blank.

    Can you please help me fixing this issue.

    Best regards,
    -Sony

Viewing 15 replies - 1 through 15 (of 45 total)
  • Hey Sony,

    I’ve go the same issue here … all plugins/themes updated fine, but the core update just goes to an empty Admin page after entering details.

    Same here on many different sites. There does not seem to be any php error or notice in the logs.

    Matt Gibson

    (@gothickgothickorguk)

    Yup, seeing the same thing here, but only on one particular site. Nothing in the server error logs. Plugins went fine *before* I tried to update core, but reproducibly I just get a “blank” page after attempting an (FTP) update of core from 4.1 to 4.1.1. (Screenshot.)

    Same here. No errors just blank page after FTP username and password.

    Ok, this worked for me: http://stackoverflow.com/questions/28598547/wordpress-core-update-fail

    just add below code into your theme function.php.

    define(‘FS_METHOD’, ‘direct’);
    after add this code WordPress not ask FTP details. so check after adding this code i hop this is working for you.

    I’ve put code into wp-config.php and works as well.

    I use plugin ssh2 to update , I hope it will work

    No it seems to work but after it tells that update-core has no right permissions , also giving it 777 it doesnt work,
    all these problems when before it ever worked without to change any permission ,
    why ?

    Matt Gibson

    (@gothickgothickorguk)

    I don’t want to change to FS-based update rather than FTP—my setup is FTP for a reason—so I’m hoping there’s another solution apart from “don’t use FTP any more”…

    We got the same problem at all our (Dutch) WordPress sites on a VPS.
    The screen turns blank after submitting the FTP credentials. (screenshot)

    WP_DEBUG shows nothing and the solution mentioned above (FS_METHOD) returns “Could not create directory. Installation Failed“. (screenshot – Dutch message)
    Switching to the default language (en_US) also results in “Could not create directory. Installation Failed“.

    Sidenote; updating manually works fine (so far) but that’s not a solution.

    I got the same problem at my WordPress site (Russian). When i placed FS_METHOD at wp-config.php, WP returns “Could not create directory. Installation Failed”. Then i change rights 777 at wp-content/upgrade.
    And now WordPress returns “You do not have sufficient permissions to access update-core.php”.

    same here ratatuil

    I assume that the new version has some problem with the rights that interferes with normal renewal and returns blank screen.

    I was able to update by adding the FTP settings to wp-config.php :

    define( 'FTP_USER', 'ftpusername' );
    define( 'FTP_PASS', 'ftppassword' );
    define( 'FTP_HOST', 'ftp.hostname.net:21' );

    randymelder:

    Did you get any error messages or any kind of problems after the update?

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘WordPress upgrade from 4.1 to 4.1.1 – blank screen’ is closed to new replies.