Support » Fixing WordPress » WordPress updates to 5.2.3 but keeps saying 5.2.2 is available?

  • Resolved Machiavelli

    (@dmachiels)


    Hi guys, I just wanted to reach out for some thoughts on an issue I’m experiencing as of lately.

    I’m trying to update from 5.2.2 to 5.2.3. When using auto-update, WordPress runs through the update process as expected, briefly shows me the steps taken (Downloading update from…, unpacking the update, verifying the unpacked files, etc.) ending with the message “WordPress updated successfully” before redirecting me to the About WordPress screen. Here comes the kicker: instead of being welcomed to version 5.2.3, I’m being welcomed to 5.2.2 – the current version. Additionally, the prompt notifying me 5.2.3 is available remains visible and WordPress appears to be at version 5.2.2. still.

    Here’s what I’ve tried so far:
    – Do a manual upgrade, overwriting wp-admin, wp-includes and the everything in the root directory except for wp-config.php, then running the database upgrade which said nothing needed updating
    – Deleting the upgrade directory in wp-contents
    – Recursively re-set all directory and file permissions, just in case
    – Disabling all plugins, then re-trying the update process

    But so far, no luck with any of this. Does anyone have any other ideas I might try?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Davood

    (@binarywc)

    Sounds like a caching issue to me. Who are you hosting the website with?

    Machiavelli

    (@dmachiels)

    Hi Davood, I’m hosting the site on my own Debian-based VM running in Azure. I also don’t have any caching plugins installed and I’m not using a CDN or anything like that.

    • This reply was modified 1 month ago by  Machiavelli.
    Davood

    (@binarywc)

    Okay, in that case I am at a loss. I am sure someone else who volunteers here in the forums will be able to provide some insight though. Please remain patient as it is the weekend so many of the other volunteers are not around as much.

    Machiavelli

    (@dmachiels)

    No worries, it’s not urgent – just something I’m unable to wrap my head around myself.

    Roy Verrips

    (@rverrips)

    I saw this on a few of my WordPress sites as well.

    First, just ensure that 5.2.3 is correctly installed by running below command from ssh shell in the installation:

    wp core verify-checksums --version-5.2.3 
    

    If the installation verifies perfectly, the it could be php OPCache (Which is was in my case). To clear the cache, do the following (change for you particular version of PHP)

    sudo -S service php7.3-fpm reload
    

    Hope that helps!

    • This reply was modified 1 month ago by  Roy Verrips.
    Roy Verrips

    (@rverrips)

    I saw this on a few of my WordPress sites as well.

    First, just ensure that 5.2.3 is correctly installed by running below command from ssh shell in the installation:

    wp core verify-checksums --version-5.2.3 
    

    If the installation verifies perfectly, the it could be php OPCache (Which is was in my case). To clear the cache, do the following (change for you particular version of PHP)

    sudo -S service php7.3-fpm reload
    

    Hope that helps!

    • This reply was modified 1 month ago by  Roy Verrips.
    Machiavelli

    (@dmachiels)

    After some more tinkering, I’ve come to the conclusion that some processes were failing due to memory issues. I’ve since scaled up my virtual machine and tweaked caching settings, and the problem was resolved.

    I’ve also noticed that, after a while, WordPress would auto-retry the update and in some instances, the task would succeed on some of my websites.

    Opcode caching would have been a possible root cause as well in this case, yet I had already tried rebooting the entire server earlier.

    • This reply was modified 1 month ago by  Machiavelli.
    Davood

    (@binarywc)

    Thank you for sharing the solution with us. It may help others in the future! Feel free to post here any time should you need help. We are happy to help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.