WordPress.org

Support

Support » How-To and Troubleshooting » WordPress updated, now database errors

WordPress updated, now database errors

  • My hosting company updated to 2.6 and now I have this error message several places on my blog:

    WordPress database error: [Table ‘gdrennon_wrdp1.wp_terms’ doesn’t exist]
    SELECT t.*, tt.*, tr.object_id FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON tt.term_id = t.term_id INNER JOIN wp_term_relationships AS tr ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN (‘category’, ‘post_tag’) AND tr.object_id IN (153, 151, 150, 149, 148, 147, 146, 145, 144, 143) ORDER BY t.name ASC

    I also can’t log-in to my dash board any longer. I have had the password reset and sent to me 3x and it won’t let me log in!

    HELP!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Sounds like the database wasn’t upgraded. Try a forced database upgrade.

    http://codex.wordpress.org/FAQ_Installation#How_do_you_force_a_database_upgrade.3F

    Thank you so much for the link & answer.

    Unfortunately, because I cannot log in to my admin section, I can’t do what they’re instructing. Is there a way to edit the file via FTP or another way?

    TIA!!

    …I cannot log in to my admin section…

    If you cannot login and access wp-admin/options.php then you’ll need to access the database directly through phpMyAdmin.

    By some miracle I figured this out. Fortunately my hosting company had phpMyAdmin already installed. I went in and changed the number in db_version and it still has the same error. If by some chance I was mistaken on what version I had before, I tried ALL the numbers and each time the error was still there.

    Any other thoughts??

    Thanks!

    Have you run the upgrade script?

    yoursite.com/wp-admin/upgrade.php

    While in phpMyAdmin can you see wp_terms?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress updated, now database errors’ is closed to new replies.
Skip to toolbar