WordPress.org

Forums

WordPress updated, now database errors (6 posts)

  1. gdrennon
    Member
    Posted 6 years ago #

    My hosting company updated to 2.6 and now I have this error message several places on my blog:

    WordPress database error: [Table 'gdrennon_wrdp1.wp_terms' doesn't exist]
    SELECT t.*, tt.*, tr.object_id FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON tt.term_id = t.term_id INNER JOIN wp_term_relationships AS tr ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('category', 'post_tag') AND tr.object_id IN (153, 151, 150, 149, 148, 147, 146, 145, 144, 143) ORDER BY t.name ASC

    I also can't log-in to my dash board any longer. I have had the password reset and sent to me 3x and it won't let me log in!

    HELP!

  2. Len
    Member
    Posted 6 years ago #

    Sounds like the database wasn't upgraded. Try a forced database upgrade.

    http://codex.wordpress.org/FAQ_Installation#How_do_you_force_a_database_upgrade.3F

  3. gdrennon
    Member
    Posted 6 years ago #

    Thank you so much for the link & answer.

    Unfortunately, because I cannot log in to my admin section, I can't do what they're instructing. Is there a way to edit the file via FTP or another way?

    TIA!!

  4. Len
    Member
    Posted 6 years ago #

    ...I cannot log in to my admin section...

    If you cannot login and access wp-admin/options.php then you'll need to access the database directly through phpMyAdmin.

  5. gdrennon
    Member
    Posted 6 years ago #

    By some miracle I figured this out. Fortunately my hosting company had phpMyAdmin already installed. I went in and changed the number in db_version and it still has the same error. If by some chance I was mistaken on what version I had before, I tried ALL the numbers and each time the error was still there.

    Any other thoughts??

    Thanks!

  6. Len
    Member
    Posted 6 years ago #

    Have you run the upgrade script?

    yoursite.com/wp-admin/upgrade.php

    While in phpMyAdmin can you see wp_terms?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.