WordPress.org

Support

Support » Plugins and Hacks » WP Maintenance Mode » wordpress update 3.5.2, maintenance mode slow down site.

wordpress update 3.5.2, maintenance mode slow down site.

Viewing 15 replies - 1 through 15 (of 27 total)
  • Same problem here! Also absolutely sure it’s wp maintenace mode causing this. Hope this can be fixed!

    Solution: Disable

    Support:
    By activating this option, you are agreeing to the fact that our code may show a random link to all search robots, this enables us to get a donation for develop on free plugins. Do not worry however, this code will not affect your site in anyway, and nothing displays to the visitors of your website nor will it slow your website down.

    in the settings.

    I have the same problem, the site is not showing up, after Maintenance Mode is aktivated. 505 Internal Error is displayd on the screen.

    Has somebody any idea for another plugin, to use instead of Maintenance?

    Thanks

    Confirming loading mostly untill PHP max_execution time is reached.

    From PHP-FPM (5.4.x) slowlog:

    [0x00007f23a2d13838] file_get_contents() /var/www/clients/client1/web1/web/wp-content/plugins/wp-maintenance-mode/inc/key-check.php:47
    [0x00007f23a2d136b0] lrss_check_update() /var/www/clients/client1/web1/web/wp-content/plugins/wp-maintenance-mode/inc/key-check.php:52
    [0x00007fff91fa7050] lrss_updatefunction() unknown:0
    [0x00007f23a2d12eb8] call_user_func_array() /var/www/clients/client1/web1/web/wp-includes/plugin.php:487
    [0x00007f23a2d12c00] do_action_ref_array() /var/www/clients/client1/web1/web/wp-includes/query.php:2872
    [0x00007f23a2d12af8] have_posts() /var/www/clients/client1/web1/web/wp-includes/query.php:743

    After disabling this Plugin site runs perfect again. Note: Maintenance site is loading fine if “Maintenance mode” is actually enabled.
    Other than stated by emielm it’s not resolved by disableing the “Support” option.

    Same problem

    Same here, I have deactivated it and sites back to loading rapidly. I have also checked the “Support” in the settings, and with that set to FALSE I get full performance back again. So no need to deactivate, just change settings.
    LenW

    Same problem on two sites here. I have however set Support: to False and the sites went back to normal.

    Setting “Support” to False fixed my site too. It also cleared up the problem I reported in my other thread. http://wordpress.org/support/topic/second-user-cant-view-site-when-logged-in?replies=2

    I was up until midnight last night coming to the same conclusion that this plugin was drastically slowing down my site. When I used the Network option (F12 in Chrome and Safari) I found that most of the time the page that was having trouble loading would finally load after about 2 minutes. Deactivating the plugin made my website immediately responsive again.

    Based on the conversations in this post, I reactivated the plugin and set Support to False. My website is still responsive.

    Looking at the Changelog, the Support feature was added in the current release 1.8.9.

    Thanks for these comments

    I was have having the same problem on our multisite install and trying to figure out where the issue was

    I really like this plugin so I am hoping that this gets addressed soon

    I’ve been hit with this as well and disabling the “Support” option resolved the internal server errors I’ve been receiving.

    This thread has been very helpful!

    Peace…

    Had this problem as well. This was NOT caused by an upgrade or any other change; this is 100% caused by the maintenance mode plugin’s back end. I neither upgraded nor made any other change to the site configuration, but my users started reporting problems about 8 hours ago (the same time this thread started). Setting the ‘support’ option to false didn’t work for me, I had to disable the plugin entirely.

    The culprit is the lrss_check_update() function in key-check.php (see MadMakz’s post above). New Relic monitor confirmed that in every case lrss_check_update hangs and times out after 120 seconds (that being the default for my particular configuration):

    Component		Total(ms)  %	Max(ms)	Call count
    
    lrss_check_update	120,000	99.8%	 120,000	1
    Internal fun...	 	41.1	0.0341%	 41.1	 	1
    apply_filters	 	15.1	0.0125%	 0.15	 	3,490
    wpdb::query	 	12.5	0.0104%	 1.45	 	32
    get_option	 	6.66	0.0055%	 0.04	 	339
    translate	 	5.67	0.0047%	 0.02	 	1,010
    etc.


    WTF??? I won’t be using this plugin again. Ever.

    Awesome! Thank you @mpd2002 and @madmakz for tracking this down. I opened up the key-check.php file and looked at the lrss_check_update() function and located the problem:

    $reqUrl = "http://wordpress.cloudapp.net/api/update/?&url=". $request . "&agent=". $agent. "&v=" . $v. "&ip=".$ip . "&p=" . $pluginId;

    Try to go to that URL and you can see the service is unavailable. So either comment out this line and leave the plugin activated (dunno how it affects it) or just remove the plugin and it should be good to go!

    Thanks again! Our customers were having this issue and now I have a solution to give them 🙂

    I am guessing that this is to check for updates to plugin. The weird thing is that cloudapp.net is a domain used by W*ndows Azure cloud services. What is wordpress doing using a W*ndows service??? Surely there are better (and to the point, more appropriate) cloud services out there.

    Glad this was at the top of the chain in the support forum. I used P3 Plugin Profiler to see that WP Maintenance was causing 99% of the slowness. But that said, this is the kind of plugin that you SHOULD be deactivating when you’re not using it. There’s no reason for it to be running while your site is live. Yes, it was a pain to figure out what is going on here, but it’s a free plugin that does a great job, no need to exagerate the problem.

    Thanks to mpd2002 and JacobN for not only finding the source of the problem, (not just a workaround) but suggesting a fix. That’s what this community is for, now the plugin author can fix it because of feedback.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘wordpress update 3.5.2, maintenance mode slow down site.’ is closed to new replies.
Skip to toolbar