Support » Plugin: WP Native Dashboard » WordPress Translation Files

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author codestyling

    (@codestyling)

    How did you setup your local server (OS, HTTP Server, Folders etc.)?
    What in detail meens “does not work”?
    I’m using it since starting with this plugin always at remote and locale installations, even using Windows XAMPP and Windows Subdomain installs.

    I have the same problem. XAMPP 1.8.1 installed to C:\xampp\ dir:
    Apache 2.4.3
    MySQL 5.5.27 (Community Server)
    PHP 5.4.7 (VC9 X86 32bit thread safe)

    Windows 7 x64, direct connection without router or firewall

    clean installation of WordPress 3.5.1.

    When I click “check repository ยป” nothing happens.
    Although I can access repository using my browser.

    built-in wordpress update system works fine

    I can’t even see javascript that should check svn repository in source code of the settings page

    Plugin Author codestyling

    (@codestyling)

    Assume, that this is a local install at a testing environment, I would be interested, how did you setup the WordPress.
    There are different ways: a) as a vhost b) as subfolder within already existing htdocs folder.
    Furthermore I need to know, if you have patched .htaccess and how the blog and site setttings been set.

    BTW: Did you check using Firebug for Firefox, if the scripts are tried to load from a non existing path (404)?

    I deleted everything in the htdocs folder. Then I unzipped the latest wordpress and installed it. So it looks like this: http://s006.radikal.ru/i213/1302/00/92f46287450a.png

    and avaiable at http://localhost/ or http://127.0.0.1/

    I changed nothing in xampp settings. The only thing I changed in WordPress, is Permalink Settings. You can see it in .htaccess file.

    And yes, there are no errors in Console and every script is loaded (I can see it in Network Tab)

    When I click on the “check repository” link it adds #svn hashtag to the url, so it looks like “http://localhost/wp-admin/options-general.php?page=wp-native-dashboard#svn” and nothing else happens after that

    Plugin Author codestyling

    (@codestyling)

    Not explainable for me. Did you also try another browser than chrome too?
    There is no reason why it doesn’t work, except the PHP environment can’t perform wp_remote_get() calls properly or the ajax requests are send to the wrong WordPress file (path problem).

    Yes. It doesn’t work in IE9 as well.
    I’ll repeat myself. I can’t even see javascript code that should be included in admin header.
    So in wp-native-dashboard/automattic.php
    line add_action(‘admin_head’, array(&$this, ‘on_admin_head’)); doesn’t work for some reason

    Javascript functions from this file don’t exist on the page, so the link does nothing

    proof:
    If I add “console.log(‘1’);” right after “//<![CDATA[“, I don’t see it in my Console.

    Also, if I make this

    if (function_exists ('add_action')) {
    		header('Status: 403 Forbidden');
    		header('HTTP/1.1 403 Forbidden');
    		exit();
    }

    nothing breaks, but it should send Forbidden headers. I tried to reactivate plugin, nothing changes. Any ideas? Maybe this file should be included earlier or in another way?

    Found it.
    If I comment condition in wp-native-dashboard.php:
    line 268

    //if (($this->options->enable_login_selector || $this->options->enable_language_switcher || $this->options->enable_adminbar_switcher) && (is_admin() || defined('DOING_AJAX'))) {
                require_once(dirname(__FILE__).'/automattic.php');
    			$this->automattic = new wp_native_dashboard_automattic($this->tagged_version, $this->root_tagged_version);
    			$this->_load_translation_file();
    			if (is_admin()) wp_enqueue_script('jquery');
    		//}

    everything works fine, include svn checking.

    print_r("\n\$this->options->enable_login_selector\n");var_dump($this->options->enable_login_selector);
    print_r("\n\$this->options->enable_language_switcher\n");var_dump($this->options->enable_language_switcher);
    print_r("\n\$this->options->enable_adminbar_switcher\n");var_dump($this->options->enable_adminbar_switcher);
    print_r("\nis_admin()\n");var_dump(is_admin());
    print_r("\ndefined('DOING_AJAX')\n");var_dump(defined('DOING_AJAX'));
    print_r("\n(is_admin() || defined('DOING_AJAX'))\n");var_dump((is_admin() || defined('DOING_AJAX')));
    print_r("\n(\$this->options->enable_login_selector || \$this->options->enable_language_switcher || \$this->options->enable_adminbar_switcher)\n");var_dump(($this->options->enable_login_selector || $this->options->enable_language_switcher || $this->options->enable_adminbar_switcher));
    print_r("\n((\$this->options->enable_login_selector || \$this->options->enable_language_switcher || \$this->options->enable_adminbar_switcher) && (is_admin() || defined('DOING_AJAX')))\n");var_dump((($this->options->enable_login_selector || $this->options->enable_language_switcher || $this->options->enable_adminbar_switcher) && (is_admin() || defined('DOING_AJAX'))));
    $this->options->enable_login_selector
    bool(false)
    
    $this->options->enable_language_switcher
    bool(false)
    
    $this->options->enable_adminbar_switcher
    bool(false)
    
    is_admin()
    bool(true)
    
    defined('DOING_AJAX')
    bool(false)
    
    (is_admin() || defined('DOING_AJAX'))
    bool(true)
    
    ($this->options->enable_login_selector || $this->options->enable_language_switcher || $this->options->enable_adminbar_switcher)
    bool(false)
    
    (($this->options->enable_login_selector || $this->options->enable_language_switcher || $this->options->enable_adminbar_switcher) && (is_admin() || defined('DOING_AJAX')))
    bool(false)

    So, if I check, for example, “extend Backend Admin Bar with a language quick selector.“, condition is satisfied and everything works.
    Fix it please ๐Ÿ™‚

    Plugin Author codestyling

    (@codestyling)

    You do not use any type of switcher either dashboard admin bar, login screen?
    May be, I didn’t test this case cause it seems to be senceless to use the plugin only as a download bridge. Will check this an will find a solution.

    Yeah, I was going to use this plugin to download translations for old versions of WordPress.

    Thanks maxkorz – exactly same issue and your solution worked.

    Hi! I need German language, but when i click “downloads” no such language there. Where to get it and how to install?

    ok i fixed self… just copied files all files in wp-content/languages from german installation zip

    It’s works! thanks maxkorz

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘WordPress Translation Files’ is closed to new replies.