Support » Plugin: Jetpack by WordPress.com » WordPress stats no longer working since past 48 hours

  • It seems since we applied JetPack 4.3.1 stats on site dashboards are no longer functioning. Instead of the bar chart here is the error:

    API URL: “https://dashboard.wordpress.com/wp-admin/index.php?noheader=true&proxy&blog=11361560&page=stats&chart&unit=1&color=fresh&width=386&height=175&j=1:4.3.1”
    http_request_failed: “cURL error 7: Failed to connect to dashboard.wordpress.com port 443: Connection timed out”

    Any guidance on how to fix it?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello,

    I also struggle with similar problems. I have WordPress RSS feed errors, too. Might there be a connection? I had problems with the this Jetpack update, the update process itself couldn’t be finished always normally. I tried it a few times.

    Plugin Author Ryan Cowles

    (@ryancowles)

    Happiness Engineer

    @pro99: I had a look at your site, and everything seems to be set up properly. You should be able to access your Stats in your dashboard, and on WordPress.com:
    https://wordpress.com/stats/

    If you continue to experience trouble, can you please try to disconnect and then reconnect Jetpack from WordPress.com? To do so, click on Jetpack from your site’s Dashboard and scroll all the way down where you’ll see a link that says “Disconnect from WordPress.com”. Click that to disconnect.

    To reconnect, click the green button that says “Connect to Get Started” and follow the prompts.

    Please let me know how that works for you, and we can go from there!

    @weigertj: Could you please start your own thread, as per the Forum Welcome?

    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

    @ryancowles thanks for taking a look. The “new stats” work after disconnecting and reconnecting. Though on reconnection attempt I got another error: transport error – HTTP status code was not 200 (520). Tried a second time, it said “you are already connected”, and showed the new stats. Old stats are what broke since last week:
    – when looking at the external site, the admin bar at the top usually shows hourly stat bar charts. These now show the broken icon of a non-existent image with no data.
    – when logging in, in the main dashboard, stats also don’t display, show the error I pasted in the first post above. Can the new stats be used for these two?

    • This reply was modified 10 months, 2 weeks ago by  pro99.
    Plugin Author Ryan Cowles

    (@ryancowles)

    Happiness Engineer

    Thanks for giving that a shot. Could you try to temporarily disable all other plugins on your site? Then, see if the issue is resolved. If it is, enable each plugin one at a time to determine which one is causing the issue. This will allow us to determine if some sort of plugin conflict is responsible for the trouble.

    If the issue does persist with all other plugins disabled, could you temporarily revert to a default theme, such as Twenty Sixteen? That way we can rule out a theme conflict as well.

    Let me know how that goes!

    We’re seeing the same behavior on about 15 of our sites. On one site we deactivated all plugins. Themes are all different across the sites. We also turned off CloudFlare. No change.

    Asking the host, Rackspace, to take a look they claim not seeing this issue on other sites running on their platform with similar configuration as ours. This is what their Linux engineer wrote:

    “I tried in multiple browsers and received the same errors repeatedly:
    Refresh the page again.

    Doing this would then throw out the same errors you were seeing, along with the API URL it was trying to hit. Please try reconnecting it one more time and, if possible, set WordPress to debug mode to see if it can provide more information.

    There are no errors being produced other than those within the application itself, as our system is not logging any PHP errors that would indicated an outright system problem. Additionally, the connection is timing out rather than outright being refused, and a traceroute from the system to dashboard.wordpress.org is producing latency/packet loss at or after Comcast.”

    We also edited the wp-config file for one site with define( ‘WP_DEBUG’, true ); and define( ‘WP_DEBUG_LOG’, true );. No log file is being produced under /wp-content. All we see is the connection timeout in Stats in the Admin Dashboard. Happy to give you access to one of our sites for you to take a look.

    We are seeing this issue on all our sites hosted at Rackspace Cloudsites

    @madjax, good to know. Have you contacted Rackspace? We have a ticket open with them, so far they think we are the only ones having that problem. It seems like the new JetPack is not connecting with their network.

    • This reply was modified 10 months, 2 weeks ago by  pro99.
    • This reply was modified 10 months, 2 weeks ago by  pro99.

    @pro99 update: they are working now!

    Great! Not for us yet though.

    Plugin Author Ryan Cowles

    (@ryancowles)

    Happiness Engineer

    @pro99: Thanks for the update. The 520 error suggests that it might be an issue with Cloudflare:
    https://support.cloudflare.com/hc/en-us/articles/200171936-Error-520-Web-server-is-returning-an-unknown-error

    Could you try to temporarily disable Cloudflare once again, and see if the same error code persists?

    @madjax: Can you ask Rackspace for more information about the issue, and how they were able to resolve it?

    Thank you both!

    @ryancowles: I never contacted Rackspace on this issue as it seemed to resolve itself. That being said, I just went to confirm that it was fixed, and it was broken again – site stats not loading on dashboard. I visited the debug page to see if there was any info there, and then returned to the dashboard, and all of a sudden the stats are loading again. So it seems to be intermittent, but still consistently a recurring issue on dozens of sites on Cloud Sites

    Same issues as @madjax, this happens to all our Cloud Sites with 100% consistency.

    @ryancowles here are the configs we tested:
    – removing all plugins, changing theme
    – pausing cloudflare (disables everything)

    None of these resolve the problem. Stats do show in the new JetPack charts, what broke since WP 4.6 and JetPack 4.3 are just the old stats, so we know stats are getting counted, but not getting rendered. In itself it’s not a sev1 issue. It does us suspicious that something in the communication protocols has stopped working and could impact critical functions of WordPress. Happy to share an account with the JetPack team for you to see directly.

    Plugin Author Ryan Cowles

    (@ryancowles)

    Happiness Engineer

    @pro99: Sorry for the delay! Can you please use Jetpack’s Debugger module to send us some more information about your site? To do so, follow these steps:

    1) Go to the Jetpack page in your dashboard.
    2) Scroll down to the bottom and click “Debug”
    3) Click the link that says “Click here to contact Jetpack support.”
    4) Fill in your name, email address, and the description box with a link to this thread.
    5) Click the “Contact Support” button to send us the debug results privately. It’s best not to post this information on public forums, as it contains private details about your site.

    Then we’d be happy to look into this further. Let me know if you have any questions. Thanks!

    I submitted my debugging info, hope it helps. Still seeing inconsistent behavior on Jetpack dashboards hosted at Rackspace Cloud Sites. There’s also a cURL timeout error in Chrome’s console when the stats won’t load.

    Thanks @ryancowles, just sent you the JetPack debug log via the contact form.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘WordPress stats no longer working since past 48 hours’ is closed to new replies.