Support » Fixing WordPress » WordPress SSL Redirect Loop Issue, on Nginx-sp, Ubuntu 14.04 & ServerPilot

  • Resolved calvinseng90

    (@calvinseng90)


    Hi all,

    I’m trying to convert my current website – http://www.calvinseng.com to HTTPS, hosted on DigitalOcean.
    I managed to install the cert from Comodo properly, but the CSS & Jquery are all broken when I’m trying to access HTTPS. I knew this is an enqueue issue, so I tried all the solutions stated on all searches I found on Google & WordPress but to-no-avail and fallen to redirect loop/broken HTTPS website(including wp-admin), if I try to force HTTPS.

    Below are the measures I took, but faced redirect loop right away
    1. Disabled all plugins & deleted all caches
    2. WP & web URL set from HTTP -> HTTPS
    3. Installed SSL insecure content fix plugin (no changes to my broken HTTPS)
    4. Installed force HTTPS (redirect loop)
    5. Altered wordpress.conf in Nginx-sp (Added server HTTP_X_FORWARDED_FOR https; Redirect loop)
    6. Broke server blocks in wordpress.conf into 80, and SSL, 443(Redirect loop)
    7. Checked WordPress core files & Theme files (No HTTP hard coded)
    8. Altered the wp-config with following values
    define(‘WP_SITEURL’, ‘https://www.calvinseng.com’);
    define(‘WP_HOME’, ‘https://www.calvinseng.com’);
    define(‘FORCE_SSL_ADMIN’, true);
    define(‘FORCE_SSL_LOGIN’, true);
    if ($_SERVER[‘HTTP_X_FORWARDED_FOR’] == ‘https’)
    $_SERVER[‘HTTPS’]=’on’;

    Redirect loop again…

    9. Contacted support on DigitalOcean. They failed to give me an answer
    10. I suspect it’s reverse proxy server, but I have 0 idea what to do about it. Seeking help at here

Viewing 5 replies - 1 through 5 (of 5 total)
  • I had a similar issue, and I think it’s due to the fact that Serverpilot use Cloudflare, and SSL wise it was causing issues similar to what you were describing.

    The only solution (I found) was pay for Serverpilot. Probably not what you want to hear but it fixed the issue I was having.

    Thread Starter calvinseng90

    (@calvinseng90)

    I don’t mind paying ServerPilot.
    Can you describe what did you do to solve it?
    I know that ServerPilot has the SSL tab opened once paid, not sure if installing the cert once again at ServerPilot helpful?

    I described it a bit here – https://winwar.co.uk/2015/05/setting-up-ssl-for-wordpress-on-digital-ocean-using-serverpilot/ – (point 5).

    If you install the Cert with serverpilot, that should solve this issue you were having.

    Thread Starter calvinseng90

    (@calvinseng90)

    Hi Rhys,

    You’re exactly right. Somewhat WordPress is working fine if I install the SSL on ServerPilot

    but now the domain is having funny issue –
    index page is redirecting from https://www.calvinseng.com to https://www.calvinseng.com/www.calvinseng.com/

    and that caused redirect loop on the index and the rest of the pages. but at least, the backend is up.

    Thread Starter calvinseng90

    (@calvinseng90)

    Problems solved.

    Follow the following steps
    1. Restore to the latest snapshot when your website is working properly fine in HTTP.
    2. Delete and clear all cached files
    3. Disable all plugins and select the default WordPress theme
    4. Select default permalink, delete any content in .htaccess, leave it empty to reset
    5. Remove any previous SSL configuration on server, especially on Apache/Nginx configurations(DigitalOcean)
    6. Remove any other mod/conf installed on server, such as PageSpeed
    7. Install SSL at ServerPilot
    8. Log into wp-admin & ensure no redirect loop
    9. Update Site & Home URL from HTTP -> HTTPS
    10. Activate your theme
    11. Enable core plugins one by one to check insecure content(HTTP)
    12. Skip this step if a green lock is seen; Else, fix the mixed content by removing “http:” on the link(for eg http://www.” inside plugins, leaving only “//www.”
    13. Update your permalink
    14. If you encountered error 404 on certain post/page, update & save it again and you should see it showing fine now.
    15. Reconfigure any mod to assure HTTPS is working instead of HTTP.

    Your site should be running fully in SSL now.
    Cheers!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress SSL Redirect Loop Issue, on Nginx-sp, Ubuntu 14.04 & ServerPilot’ is closed to new replies.