• SSL is already installed on my website and I can access it with HTTPS.
    My WordPress settings are:
    WordPress Address (URL): https://www.mydomain.com
    Site Address (URL): https://www.mydomain.com
    But when I open http://mydomain.com or http://www.mydomain.com, I am not automatically redirected to the SSL and WWW versions of my website.
    I don't want to modify the htacess file or install any plugin.
    Why is WordPress's automatic redirect not working? Can someone please help?
Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p


    Thread Starter kinngjatt


    I do not have any SSL problems. Just the redirect problem. I have already updated the site URL in the settings. But HTTP and HTTPS both are working. I want to redirect to HTTPS without using any plugin or modification.

    On my other website just updating the Site URL works and WordPress automatically redirects the http to https.

    But I think a glitch has occurred which is not allowing the WordPress to perform the redirect,

    Moderator t-p


    That tutorial has these following tips. Have you tried this:

    3. Fix Too Many Redirects Errors After Moving to SSL / HTTPS
    WordPress allows you to enforce SSL / HTTPS for the admin area by entering the following line into your wp-config.php file.
    define('FORCE_SSL_ADMIN', true);
    However, in some scenarios this setting alone would cause ‘Too many redirects‘ error. To fix this, you will need to add the following code to your wp-config.php file just before the line that says ‘That’s all, stop editing! Happy blogging.’.
    define('FORCE_SSL_ADMIN', true);
    // in some setups HTTP_X_FORWARDED_PROTO might contain 
    // a comma-separated list e.g. http,https
    // so check for https existence
    if (strpos($_SERVER['HTTP_X_FORWARDED_PROTO'], 'https') !== false)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress Site URL redirect not working’ is closed to new replies.