Support » Fixing WordPress » WordPress Site & Plug-in Updates

  • My site is hosted at GoDaddy and I have the latest version of WordPress installed, but when I see updates for WordPress or the plug-ins I have small issue, and I need to know how concerning this is…

    In the past, and how I believe WordPress is supposed to work, it’s supposed to show me how many updates there are to apply and then gradually show those to me as they’re being applied, and then tell me the updates are complete; mine doesn’t.

    My WordPress goes to the update screen, starts the updates, it shows me [like] installation 1 of 6 and then it stops; there’s NO more visual/gradual updates on the screen.

    But I know the update process is working the background… because if I give it about 30 seconds, and go back to the dashboard, there’s no updates and the plug-ins are current.

    So, I’m a little concerned about not seeing these gradual/visual updates, but how serious is it; and it’s anyone else seeing these issues?
    What would prevent it from showing update progress?
    Can it be fixed?

    Anyone have any ideas or thoughts on this issue?
    I appreciate it…

    Thank you,
    Larry Henry Jr.

Viewing 13 replies - 1 through 13 (of 13 total)
  • It is a godaddy issue.

    About a year and a half ago, all my sites started doing that.

    I have several WP installs on godaddy, they all behave that way. I tried working with godaddy, and finally gave up.

    There is no harm in this behaviour. I simply wait until I can see that the update page has finished loading. When it is no longer loading, the update is finished

    You indicated this is a GoDaddy issue…
    Can I ask the nature of the steps and conversations you had with them; just so I’ve got a better understanding?

    And thanks for getting back with me; your time is appreciated…

    Until next time,
    Larry Henry Jr.

    ME: “Hi my update progress isn’t working”

    THEM “It should be, we didn’t do anything”

    ME: “It isn’t, you just upgraded your hosting”

    THEM: “It should be, what we did wouldn’t affect that”

    ME: “It’s not, and it did”

    THEM: “You’ll need to research the problem, its a wordpress issue”

    Multiplied by 7

    Sorry, I didn’t keep the emails. The issue started right when they did an upgrade to their hosting a while back.

    It’s not worth it to me to try to get it sorted with them. I did tag your post here with godaddy, every now and then they stumble in here. Or you can try your hand at working with them, its far too frustrating dealing with their CS sometimes.

    I did make exact copies of 2 of my affected sites, and install them on localhost. Exact copies, plugns, posts, settings, etc, on localhost, the updates performed as expected. I only have the issue on my godaddy installs

    If you’re using any plugins that enable output buffering (for example, gzip compression) or are using mod_deflate on your site, this can cause the output to not appear instantly in your browser. That would explain the type of behavior you’re seeing. It is not, however, the result of any general change to Go Daddy’s hosting environment.

    If you’re using any plugins that enable output buffering (for example, gzip compression) or are using mod_deflate on your site

    I’m not.

    this can cause the output to not appear instantly in your browser.

    It dopesn’t appear ever

    Rev. Voodoo,

    I’m sorry to hear that your blog exhibits this issue. Rest assured, though, that it is not normal. Just today, I tested both a core update and a plugin update… each displayed the appropriate update text properly and completed in very short order.
    If you’re curious to see this for yourself, you can always add a new WordPress instance to your hosting account in a subfolder. Use it as a testbed to see how a fresh install works on your specific server. If you still have this problem with a fresh install (no custom theme and minimal additional plugins), I’ll want our Hosting Team to take a look at it.
    If you give it a shot, let me know how it goes by posting in this thread and, assuming you’re comfortable doing so, include a link to the blog or let me know how else to contact you privately.

    @godaddy, I appreciate the attention on this matter, I currently run 6 WP sites.

    One of them is a fresh install, completely bare bones, default theme, no plugins, which I use to test things on

    Every one of my installs exhibits that behaviour. I did just verify that again.

    my test install is at

    I have various other blogs, which I’m happy to provide links for

    I don’t have any updates yet, but I did have a GZIP plug-in installed because of the poor performance I was getting from GoDaddy hosting [not that it helped], but as soon as I get updates to the WordPress site; I’ll report back here. Many thanks…

    Until next time,
    Larry Henry Jr.

    Rev. Voodoo,

    When I view your site through with the ‘accept encoding gzip’ checkbox enabled, the response headers show it’s configured to compress the response.
    If this isn’t the result of a WordPress plugin, it might be turned on per-directory in your .htaccess file or enabled site-wide in your php5.ini file. In your case, since this is just a test install without much customization, I’m guessing it’s in the php5.ini file.

    Please take a look into those possibilities and let us know what you find.

    Did some poking around, and you were right

    zlib.output_compression = on

    in my php5.ini file. I commented that out, restarted my web processes and checked to make sure gzip was off

    Then when running updates, the display worked properly, so thanks for that. I believe years ago, I allowed someone access to my site to help get caching enabled, they must have dropped that in there.

    This of course leads to another issue… if I turn that off, my caching no longer works properly, and I get crappy load times.

    Is there no way to have the updates appear properly, and have good caching?

    Thanks for the assistance

    Rev. Voodoo,

    That’s great… so we’ve confirmed that it’s not an issue caused by the Go Daddy environment. That makes me happy 🙂

    As for enjoying both gzip and the update text in WordPress – technically, you can enable compression for a site while disabling it for a single file. It would take some work, though.

    Here’s some guidance if you (or anyone else) want to give it a shot…

    Review our tutorial for enabling mod_deflate using .htaccess:

    Then learn about how to disable a filter for a single file. These articles may help:

    OK thanks, thats good info…… just gott afigure out how to take that, and apply it to the update process

    Rev. Voodoo and lehenryjr,

    I just wanted to let you know that we took the feedback from this thread and worked on a solution. One of our developers got involved in this bug report – – and produced a patch that could resolve the issue if it’s accepted into a new version of WordPress.

    We don’t know if or when it would be accepted into the WordPress core, but I wanted to show you that we took the information gathered here and worked toward making a real change to benefit the community.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WordPress Site & Plug-in Updates’ is closed to new replies.