Support » Plugin: MailPoet - emails and newsletters in WordPress » WordPress site health detecting MailPoet error

  • Resolved ktsiterip

    (@ktsiterip)


    Just a heads up, WordPress sent me the following – Ive replaced my site name with “name hidden”

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, MailPoet 3 (New).

    First, visit your website (https://www.name hidden.com/) and check for any visible issues. Next, visit the page where the error was caught (https://www.name hidden.com/wp-admin/post.php) and check for any visible issues.

    Please contact your host for assistance with investigating this issue further.

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

    https://www.name hidden.com/name hiiden/?action=enter_recovery_mode&rm_token=CN5BWFPHclhmKVO0lzpYiY&rm_key=tuvDTa1LCCzsvcCb1spK12

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

    Error Details
    =============
    An error of type E_ERROR was caused in line 345 of the file /home/name hidden/public_html/wp-content/plugins/mailpoet/lib/Models/Model.php. Error message: Uncaught Exception: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away in /home/name hidden/public_html/wp-content/plugins/mailpoet/lib/Models/Model.php:345
    Stack trace:
    #0 /home/name hidden/public_html/wp-content/plugins/mailpoet/lib/Models/Newsletter.php(766): MailPoet\Models\Model::__callStatic(‘findArray’, Array)
    #1 /home/name hidden/public_html/wp-content/plugins/mailpoet/vendor/j4mie/paris/paris.php(99): MailPoet\Models\Newsletter::filterWithOptions(Object(ORMWrapper), ‘notification’)
    #2 /home/name hidden/public_html/wp-content/plugins/mailpoet/lib/Newsletter/Scheduler/Scheduler.php(274): ORMWrapper->filter(‘filterWithOptio…’, ‘notification’)
    #3 /home/name hidden/public_html/wp-content/plugins/mailpoet/lib/Newsletter/Scheduler/Scheduler.php(49): MailPoet\Newsletter\Scheduler\Scheduler::getNewsletters(‘notification’)
    #4 /home/name hidden/public_html/wp-content/plugins/mailpoet/lib/Newsletter/Scheduler/Scheduler.php(41): MailPoet\Newsletter\Scheduler\Scheduler::schedulePostNotification(602941)
    #5 /home/khmer

Viewing 1 replies (of 1 total)
  • Plugin Contributor MailPoet

    (@mailpoet)

    @ktsiterip truly sorry for the late reply.

    1. Ask your host to make sure you have all the required PHP extensions first:

    https://kb.mailpoet.com/article/152-minimum-requirements-for-mailpoet-3#php_extension

    2. Disable existing plugins temporarily. This may disable the unintended behavior.

    3. Temporarily switch to a different theme than the ones currently installed. Themes may add extra behavior that could be triggered in this case.

    4. Review your server’s configuration to see if there are any security plugins or extensions that may trigger such behavior.

    After each step please visit MailPoet pages to see what happens.

    Let us know!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.