Support » Localhost Installs » WordPress shows me a worng url and does not load a theme or css

  • Resolved Adri Oosterwijk

    (@adri-oosterwijk)



    I have severe problems with my local installations of websites. I am trying to restore it but have difficulties.
    I deleted and reinstalled MAMP PRO.
    I created a host to no avail
    The default “localhost” was working fine. For test purposes I placed my files overthere.

    Instead of showing the theme (with css loaded) I get a page with just the homepage content.

    When I try to access the dashboard it shows me a 404 (again without theme and css)

    The outputted url starts with this:

    http://localhost/wp-admin/localhost/wp-login.php?redirect_to

    Notice the second localhost in it.

    Does anyone knows why this is and what I can do?

    It happens also with other local hosted domains.

    BTW I migrated the database from my online server with an export of all the tables and imported it in the local database. I changed the first two options in de options table to ‘localhost’ with phpMyAdmin.
    Really don’t know wat to do next I’m struggling with it for three days now.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • stefsterNYC

    (@stefsternyc)

    Can you take screenshots of the install inside htdocs please? And no need to put a local link. Only you can view localhost

    Adri Oosterwijk

    (@adri-oosterwijk)

    @stefsternyc

    Thank you for your quick reply, I’m really stuck here.

    When I did it all correctly you can download the imag here:

    http://nl.tinypic.com/r/2quowtw/9

    Hope you can shed some light on it.

    stefsterNYC

    (@stefsternyc)

    Make sure your directories are well organized. That screenshot is a mess. LOL Sorry but true.

    Make sure your clients and installs are like this.
    https://imgur.com/a/HKw3eDh

    Make sure then that your installs look like this.
    https://imgur.com/a/EA5lL6l

    Double check your DB for any misspelled URLs. Change them in Site & Home are the url that you want for your local install. For instance my client Sentenn will be:
    http://localhost:8888/sentenn/

    Hope that helps and makes sense.

    Adri Oosterwijk

    (@adri-oosterwijk)

    @stefsternyc

    Thanks again for replying.
    However after checking my database again and again I don’t think that there are misspelled urls. Even the dynamic urls are weird.

    For instance: http://localhost/wp-admin/localhost/wp-admin/plugins.php?deactivate=true&plugin_status=all&paged=1&s=

    I hae to to delete the localhost/wp-admin/ part, hit enter and then I’m redirected with the normal plugin page.

    Going to themes: they are not recognized (no images are displayed.
    Goin to the frontend: no theme, images or css is loaded.

    It looks like the wp-content folder is not recognized or wrongly read. But why?

    stefsterNYC

    (@stefsternyc)

    Yeah but in order to work in MAMP you need to tell it which port to use and your not even telling it which port. Always, always need a port.

    You have http://localhost/ wp-admin without any port.

    Should be http://localhost/8888 or http://localhost/8889

    So, yes, me thinks you have URL issues. :o)

    A good URL would be http://localhost:8888/devmore/wp-admin/

    DEVMORE being the directory I’m working in. I like using 8888 for Apache and not 8889

    Adri Oosterwijk

    (@adri-oosterwijk)

    Sorry to disagree but you can change the port settings in MAMP to the default porst like 80.
    So this way you don’t have to enter the 8888 port in your urls.

    It worked for a long time before but yesterday MAMP crashed badly. I had to uninstall it (yeah with the uninstaller and start over.

    I downloaded the site files form my live server and exported the database.
    I did it before and that worked. Just change the first two rows in the options tabel and after that run Better Search and Replace plugin to change the other faulty entries.

    I can’t get my head around the fact that my url’s are wrong AND that the wp-content folders seems to be unavailable. The permissions are correct.

    stefsterNYC

    (@stefsternyc)

    That’s true. I wasn’t sure you were using port 80. Not too many people I know use 80 unless they’re running a multi site.

    • This reply was modified 1 month ago by  stefsterNYC.
    Adri Oosterwijk

    (@adri-oosterwijk)

    It seems to be solved.
    As it turned out a theme_mod_abcs_child field was corrupt in the database.
    I restored it from a backup and there it was again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.