Support » Fixing WordPress » WordPress Shows Comment RSS instead of Post

  • Hi,

    For the last few months I’ve been seeing something really weird. Sporadically and no for reason that I can understand, random URLs on our WP site will show a single comment RSS feed instead of the content itself. This could be page 2 of the home page, a single post page, a tag page, etc.

    The issue appears and within a few minutes, disappears. However, it doesn’t appear for all users. A user can be experiencing the issue, while other users see the site as it should be.

    Any idea what might be causing it?


Viewing 14 replies - 1 through 14 (of 14 total)
  • Is this a first? Any suggestions is greatly appreciated.



    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Hi Esmi,

    Thats whats odd. Same theme and same set of plugins (actually cloned from each other) which are 100% identical doesn’t cause the issue to happen on the other sites.

    I’ll try resetting the plugins folder and deactivating a small group of plugins at a time.

    Thanks for the suggestions.

    Hello guys – same here – this occurred after I moved my WordPress site to a dedicated host that we control. So it may be a permalink configuration or something to do with Apache. In order to get my permalinks to work again – I had to edit or add an .htaccess file or something like this to rewrite the URLS:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    To reproduce this – I installed a brand new browser today (Chrome), went to the site – the site came up fine. I click on a link across the top and the permalink showed up as: however the page was an RSS dump. Being chrome did not have an RSS reader installed. Firefox will show they typical Subscribe to this feed using….so it would be helpful to know why this is happening and how we can fix it.

    If you click refresh in the browser – THEN the proper page displays.


    OK, I was able to duplicate it again
    – instead of getting the page, I got the RSS text from this:

    Then I looked at the source from the actual page and I saw this:

    <link rel=”alternate” type=”application/rss+xml” title=”Pentaho Evaluation Sandbox » Feed” href=”” />

    <link rel=”alternate” type=”application/rss+xml” title=”Pentaho Evaluation Sandbox » Comments Feed” href=”” />

    I looked at both

    And they’re both the same – any idea why?

    I edited the functions.php of my theme and added these remove_actions

    remove_action( ‘wp_head’, ‘feed_links’ );
    remove_action( ‘wp_head’, ‘rsd_link’);
    remove_action( ‘wp_head’, ‘wlwmanifest_link’);
    remove_action( ‘wp_head’, ‘index_rel_link’);
    remove_action( ‘wp_head’, ‘parent_post_rel_link’);
    remove_action( ‘wp_head’, ‘start_post_rel_link’);
    remove_action( ‘wp_head’, ‘adjacent_posts_rel_link’);
    remove_action( ‘wp_head’, ‘wp_generator’);

    So far so good – it has not happened.


    OK UPDATE to this – I now believe it was the DB Cache Reloaded Plug-in that was causing the issue. I think what happened was the permissions for reading the cache directory were locked down and the site could no longer read the cache – so instead of the page being displayed the RSS dump was being displayed. I am still not sure – but once I disabled dbcache reloaded the problem stopped. I will updated here as I know more.

    OK this is starting to suck more and more. It seems that it is not the DB Cache Reloaded plugin or the links. It occurred just now after I updated a page on WordPress. After I clicked update in the admin console – I went to view the page and I received the issue again. It now appears that something with the update to wordpress and possibly caching on apache? – I had to force a browser refresh to see the new page. I don’t know.

    Hi Michael,

    Coincident perhaps that you’re issue was related to the DB Cache plugin. The problem I was having appears to have been related to the WP Supercache plugin and may be similar. I switched to W3 Cache and using Memcache instead of file cache and my problem has seem to went away as well. However, for me its perhaps too early to tell as the problem doesn’t seem to have predictably. So far its working fine. I’ll give it another few more days before saying for sure on my end.


    Hi Cent,

    Thanks – let’s keep one another updated. I have IT looking at this too. The only thing I know for a fact that is different, is that we switched from GoDaddy to our own dedicated host that we control. So it may be a PHP setting, an Apache Setting or something else on the system that may be difficult to track. I’ll let you know – I am still leaning on the cache issue. I have a bit more investigating to do.


    Mike T

    Still happening – even with cache control plugin deactivated. Gonna try removing the plugin and see what happens. This is really pissing me off.

    It seems to happen after the server sits for a while.

    Is there a wordpress JIRA – or bug tracker that we can report this to?

    Cent…I found this let me know – it seems that you and I are the only recent ones to experience this problem

    I’ll update you here shortly.


    Whack your feeds through Feedburner, my experience is it cleans up malformed feeds, which those of WP often are.

    Do a CNAME change and your feeds will still appear to come from your domain, plus you get stats.

    Check yr feeds with a validator.

    Nico M


    It was related to the issue I found here:

    Problem Solved


Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WordPress Shows Comment RSS instead of Post’ is closed to new replies.