Support » Plugin: Yoast SEO » WordPress SEO by Yoast – Homepage Permalink URL

  • Can an SEO expert chime in here and comment on how they handle the “homepage” url given the it should generally be in the format ( but the WordPress SEO by Yoast plugin wants the page title in the url.

    Not sure what the best way to handle this is or any suggestions on what’s working? Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Odd. Have you made sure that you’ve set a static page to display as the front page under Settings > Reading?

    Just gave it a test on my local install. With a static page set as the front page, the WordPress SEO meta box only shows the site URL in the snippet preview, as it should.

    Hi Andy, thanks for the reply. Yes, but I was referring more about the way Yoast grades my homepage. I keep getting dinged on my score because I don’t have the title in my url. Is that something I should be concerned about? If so, how are people adding their homepage title into their homepage url? Thanks.

    I cannot find the solution to this issue after searching for nearly an hour.

    My permalink setting – “a static page (select below)”
    – front page: (I have selected a page as my homepage)

    The title of the page that I have selected does indeed include my focus keywords “online tutoring.” As well, via “pages > quick edit” I have included “online tutoring” in the slug.

    But when using yoast, while editing the page, yoast tells me that the focus keyword is not found in the page url.

    Is there a solution for this or can the “no” be ignored in this particular situation because I DO have it in the slug?

    Thanks 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress SEO by Yoast – Homepage Permalink URL’ is closed to new replies.