Support » Fixing WordPress » WordPress RSS Feed gives 500 Internal Server Error

  • I’m running the latest version of WordPress, 3.0.1. Website works fine, but all RSS Feeds have this error: 500 Internal Server Error.

    I don’t know why but the comments feed: /comments/feed/ WORKS FINE.
    This is the only feed that actually works.

    I’ve tried: /feed/, /?feed=rss, /?feed=rss2, /?feed=rdf, /?feed=atom .

    All of them are stuck with 500 Internal Server Error.

    .htaccess file is ok, I’ve also tried disabling some plugins, regenerating permalinks, nothing works. I’m stuck

    Please help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    I’ve switched to the Twenty Ten theme and deactivated all plugins but I’m still getting the error.

    I’m guessing there’s something wrong in my database or somewhere. Do you know what it could be?



    Forum Moderator

    Try resetting your custom permalinks back to the default setting and deleting/renaming your WordPress .htaccess file. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

    I said in my first post that I’ve already reset my permalinks but it didn’t fix the error.
    I did as you said, I have deleted my .htaccess file but it didn’t fix it either.

    Thanks for answering though! WordPress 3.1 should be out “soon”. I don’t know how soon but anyway do you think it would fix my thing?

    What seems strange is that I’ve reset the permalinks to Default and when I click on my feed link which is: /?feed=rss2 it automatically redirects to /feed/

    I have my cache plugin disabled so it’s not the cache plugin who is redirecting I guess. At least I hope I’m getting closer into fixing this… there must be something who redirects but who and why?



    Forum Moderator

    Try re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    I just did as you told me, nothing fixed. :((((
    This is frustrating! Why is wordpress so full of bugs to begin with? 🙁

    OMG! I think I’ve found it. I found a setting in SexyBookmarks plugin which asked “Show in RSS feed?” and it was set to Yes. All I did was to choose No and reset the permalinks and the feed finally started to work again!
    It’s strange though because even though I have disabled the plugin the issue hasn’t been fixed until I reactivated the plugin and choose “No”.

    Now I hope the problem will never come back again!

    esmi thanks for your help. do you know a plugin that consumes the LEAST server resources (LESS CALLS, LESS CPU, MEMORY, BANDWIDTH, etc) for “Random Posts”? I want one that consumes least because I know that this type of plugin usually eats many resources. Thanks.



    Forum Moderator

    No problem – although I’m surprised that you didn’t stumble across Sexy Bookmarks as the culprit when you want through the “mass plugin deactivation/individual reactivation” process.

    I’m afraid I can’t recommend any of the Related Post plugins myself. I agree that they can consume an awful lot of resources if they generate the post links for each page display. I did notice one a while back that generated & stored the related links so that all of the intensive processing was carried out in the Admin area. Generated public pages then just needed to query the plugin’s db table In theory, that should significantly reduce the cpu/memory usage.

    Problem is… I can’t remember what it was called. 🙁

    It was definitely in the Plugins Directory, though – if that’s of any help.

    Thanks for your help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WordPress RSS Feed gives 500 Internal Server Error’ is closed to new replies.