Support » Fixing WordPress » “WordPress requires Cookies” error after moving to a different directory

  • I originally installed wordpress in and everything was working fine. Last night I decided to move it to the root directory of the site

    After moving, I immediately realized that I can’t access the administrator page from the new directory (root) ( and I’m getting the error that says “ERROR: WordPress requires Cookies but your browser does not support them or they are blocked.”

    I know that this got nothing to do with my browsers because:
    1. I can still login to the original wordpress directory (
    2. I have IE, firefox, opera and all of them are saying the same error.

    Do I need to modify the codes, or do something with MySQL?

    Any thoughts?

Viewing 10 replies - 1 through 10 (of 10 total)
  • ok.. I found this
    reading thru it right now… but if anyone is familiar with the process that I’m trying to do, I would appreciate a feedback.

    Step # 3 of “Moving WordPress Within Your Site” (see link the I posted above:

    3. Go to the Administration > Options > General panel.

    ***That’s the problem. I can’t even login to the administration…




    you need to put back what you moved and move wordpress ‘the right way” , or you need to go through one of these processes:

    See this:

    or this:

    or if you want it even simpler and youre using 2.3.2

    just do this:


    Thanks for the response whooami! I appreciate that.

    Just a few questions…

    What is the “right way” of moving wordpress? I used filezilla to download the everything from my catalog directory, also used it to upload the files into the root directory. if that is not the right way please enlighten me. im really new to this.

    Regarding Editing WP-CONFIG.PHP in the Advanced Options.. My problem is I can’t even login to the Administration thus I cannot access the Advanced Options. I checked the wp-config.php that I downloaded but it just contain the database info- there’s nothing about the WP-SITEURL.

    I still have the original copy of wordpress in the catalog directory though.. Is there a way for me to forward to I tried DNS forwarding but apparently it works only if the site is hosted somewhere else.




    the right way is what you were reading before,

    you went beyond that. so now you can backtrack, or fix it 🙂

    regarding editing your wp-config.php — thats a file. thats not something that you need access to wp-admin to change. You edited it when you set up WP. Remember.

    there are TWO ways to fix it .. you either change the settings in your databse, OR you make the adjustment inside your wp-config.php

    Both of them are trivial to accomplish, and mitigate the necessity of doing DNS hokey-pokey, thats a tad bit of overkill. Besides which, thats not how DNS works.




    I checked the wp-config.php that I downloaded but it just contain the database info- there’s nothing about the WP-SITEURL.

    Of course there isnt, you havent ADDED it yet. YOU are supposed to add the info to it. Its a way that was developed for just these kinds of situations because ppl cant seem to understand that they cant move things and change settings arbitrarily, and it was too damned complicated for them to get into their databses to fix.

    Editing one file is supposed to make it simple.

    PS: I apologize, I dont mean to sound so frustrated, its just the file editing was supposed to make this reallllly simple, and sometimes it doesnt seem to make a difference.

    Things are confusing to ppl the first time around, and I frequently overlook that.

    Thanks Nick Burns 😛

    Ok. I got confused about the “right way of moving” that you mentioned. But anyway, on my second post I already mentioned that I went thru that already:

    Step 1 says that if you are moving wordpress to your root directory (which is what I am trying to do) you have to make sure that the htaccess and the index.php and all the other files are moved yaddah yaddah yaddah… I did all that and moved all the files properly using filezilla.

    Step 2 says Login to your blog —> this is where the problem sets in. I can’t even login. You mentioned that I should backtrack and read this “right way” again but I am not sure which way to backtrack since I am sure that I did step 1 properly and the site is working fine but the problem is I can’t login..

    Regarding WP-SITEURL, I haven’t added it yet but I will try that.

    Thanks so much whooami. ur da best!




    Regarding WP-SITEURL, I haven’t added it yet but I will try that.

    Given your solution, thats the way I would go.

    If you need further help, you can drop me an email at whoo AT and I will give you a hand. I charge, just a cpl bucks, via paypal, just to keep ppl honest though.

    Thanks for the offer whooami! but i got it fixed! =D

    Let me share to everyone what i did,

    i created a .htaccess file with this information:

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^(www.)?$
    RewriteCond %{REQUEST_URI} !^/catalog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /catalog/$1
    RewriteCond %{HTTP_HOST} ^(www.)?$
    RewriteRule ^(/)?$ catalog/index.php [L]

    now i dont have to move the files anymore =) if somebody go to they will be automatically redirected to =)




    thats the hard way, but whatever works.

    its 2 lines in the wp-config.php

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘“WordPress requires Cookies” error after moving to a different directory’ is closed to new replies.