Support » Fixing WordPress » WordPress: redirecting to wp-admin/install.php even after reinstalling backup

  • I’m having major difficulties to regaining access to my wordpress website (was online for 2 years) and to admin login of wordpress. I’ve been searching for quite a while now to resolve this issue. I constantly got the too many redirect error and my browser was always redirected to wp-admin/install.php. I already tried the common solutions:

    Clear Your Cache and Cookies of browser,

    disable .htaccess,

    disable all plugins,

    disable theme,

    adapt wp-config.php:

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    Check/restore tables of database;

    Check wp_options table (did not find a table wp_options (or similar named) in my database)

    Nothing worked, in the end I tried the solution to reinstall my website with an old backup (generated from Duplicator – WordPress Migration Plugin) I generated in May. This issue only occurs since a few days so the backup version of the website was certainly a proper working one.

    Unfortunately still the same issue appears, the websites keeps redirecting to wp-admin/install.php.

    Anyone who has an idea what the solution could be?

    Thanks in advance & kind regards!

    • This topic was modified 1 year, 7 months ago by piepzeidekat.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi piepzeidekat

    I haven’t come across this problem myself but I googled around a bit for your error. I found a discussion on stackoverflow where the cause was uppercase table prefixes. Seems to have solved the problem for a few people.
    Here’s the link, maybe it will help you:
    https://stackoverflow.com/questions/9827164/wordpress-keeps-redirecting-to-install-php-after-migration

    Hi @brenshutt,

    Thanks for your reply, I had already found the possible solution concerning uppercase table prefixes as well. In my case the prefix of my tables is simply “wp_” and all tables consequently contain this prefix with no uppercase exception whatsoever. In my database there are no tables named “usermeta” or “inside options”, but I guess not every wordpress website should have these tables.

    Moreover when reinstalling a backup of May (which worked for sure) the same issue appears.
    Is it then save to say that the cause of the error is not in the wordpress website itself (code, database,…) but maybe something else?
    The backup of May was a version when I just changed from http to https, this change worked for sure for some months. Could this nevertheless causing the problem?
    Or maybe the cause is webhost related?

    • This reply was modified 1 year, 7 months ago by piepzeidekat.
    • This reply was modified 1 year, 7 months ago by piepzeidekat.
    • This reply was modified 1 year, 7 months ago by piepzeidekat.

    Hi @piepzeidekat
    I think it’s a good idea anyway to submit a support request with your webhost and ask if they are aware of other customers reporting a redirection problem, especially if you can narrow it down to an exact date when the problem started. You might also ask if there are any server logs available that might have captured when the redirection started.

    I am looking at your page in a Chrome browser with Developer tools and followed the instructions from this article: https://www.quora.com/How-can-I-view-the-source-code-of-a-web-page-when-it-directs-me-to-another-page-when-I-open-it
    -Open Developer Tools (F12)
    -Check the box for “Preserve Log” under the Network tab
    -go to your URL
    -click through the results

    One other thing I would try is to temporarily disable the favicon so that your troubleshooting is isolated to the home page. Favicon is probably working fine but you never know, often it’s the smallest little change that makes something break. I’m assuming that you have specified a favicon somewhere in your theme.

    Today, it looks like your host is in a service maintenance window so might not be a good time for troubleshooting.

    Good luck! I hope today is your lucky day.

    Sorry, just realized that you can’t disable the favicon if you have no way to login to your site. I guess you can check the file name for uppercase/lowercase or some other inconsistency.

    Hi @brenshutt,

    I renamed the favicon in order to disable it but this isn’t causing the issue.
    Other websites of the webhost are not having difficulties, I asked for server logs but apparently these are very big and difficult to find the redirect lines of my website.

    Thanks for the tip concerning Developer Tools. In my case the output is that the install.php is marked in red and I get the “You don’t have permission to access /wp-admin/install.php on this server”. Don’t see new info that could lead me to the root of the problem.

    Thanks for your help and suggestions! The quest continues 😉

    Hi @piepzeidekat
    Checking back in to see if you’ve had any luck. I’m out of ideas myself but still interested in the resolution. I’ll stay subscribed and hope that your issue is resolved very soon.

    Hi! I had the same exact problem.
    To resolve it I create a new database and imported the old one into the new one. It appeared that it was blocked because there were too many comments on posts and they exceeded the old database capacity, that was blocked by the provider. I disabled all comments and cleared the wp_comments table before migrating it
    Hope this help!

    Hello @piepzeidekat
    I am having the same problem right now. I opened a ticket at the webhost’s help platform and they replied that the reason of that is because of the query limit exceeded

    This fixed it for me. The issue is within wp-config.php file. You have to double check the $table_prefix field and make sure that it corresponds to table prefixes in your actual database.

    Example: if in the DB your tables look like ” wp_website_year_comments ”

    in your wp_config.php it should look like this:

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‘wp_website_year_’;

    chiefsnake

    (@chiefsnake)

    This happened to me again today (suddenly getting the install screen), first time for this particular WordPress site, though, but it has happened to me on others. So I FTP’d into the site, renamed .htaccess so it wouldn’t function, renamed install.php so that it wouldn’t function either (later WordFence alerted me that it found that renamed “unauthorized file” in my WP setup and it should be removed—cool!) and was then able to log in to my WP site OK. Then I went into Settings>Permalinks and just did a save there to re-establish an .htaccess file. When this problem first occurred, I had been doing a lot of small edits on many custom posts, so the idea of stack overflow mentioned earlier in this thread made me think that the unusually large (a few dozen) number of edits made in the span of a few minutes might have had something to do with it. Still, it’s a mystery to me of what actually triggered it to happen.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WordPress: redirecting to wp-admin/install.php even after reinstalling backup’ is closed to new replies.