WordPress.org

Support

Support » Plugins and Hacks » [wordpress popular posts] No data so far.

[wordpress popular posts] No data so far.

Viewing 15 replies - 16 through 30 (of 36 total)
  • @pixelmad, just checked your site and I’m seeing some slight differences in WPP’s javascript code. Have you modified it?

    Also, could you please check on your host’s phpmyadmin and see if there is any data on the wp_popularpostsdata and wp_popularpostsdatacache tables?

    You’ve installed WordPress on a different location, right?

    Hi Ikkie,

    Regarding ths js modification – no I haven’t, at least not knowingly 🙂 I checked PHPAdmin and both tables show zero records.

    Just in case I have deleted the plugin, re-downloaded it and am waiting to see if anything changes but nothing so far.

    Try changing this:

    <!-- WordPress Popular Posts v<?php echo $this->version; ?> -->
    <script type="text/javascript" charset="utf-8">
        /* <![CDATA[ */
    	//jQuery.post('<?php echo admin_url('admin-ajax.php'); ?>', {action: 'wpp_update', token: '<?php echo $nonce; ?>', id: <?php echo $id; ?>});
    	jQuery.post('<?php echo bloginfo( 'wpurl' ); ?>/wp-admin/admin-ajax.php', {action: 'wpp_update', token: '<?php echo $nonce; ?>', id: <?php echo $id; ?>});
        /* ]]> */
    </script>
    <!-- End WordPress Popular Posts v<?php echo $this->version; ?> -->

    … into this:

    <!-- WordPress Popular Posts v<?php echo $this->version; ?> -->
    <script type="text/javascript" charset="utf-8">
        /* <![CDATA[ */
    	jQuery.post('<?php echo admin_url('admin-ajax.php'); ?>', {action: 'wpp_update', token: '<?php echo $nonce; ?>', id: <?php echo $id; ?>});
    	//jQuery.post('<?php echo bloginfo( 'wpurl' ); ?>/wp-admin/admin-ajax.php', {action: 'wpp_update', token: '<?php echo $nonce; ?>', id: <?php echo $id; ?>});
        /* ]]> */
    </script>
    <!-- End WordPress Popular Posts v<?php echo $this->version; ?> -->

    Please let me know the results.

    Still no luck I’m afraid 🙁

    I’ve noticed this problem with my installation too. It started displaying the “Sorry. No data so far.”. Been using this plugin for a long time so I don’t see why it stopped working suddenly.

    According to the dashboard page, there are data for monthly and all-time views but the daily and weekly ones have no data as of today. It was still working yesterday.

    Tried the fix posted above but it doesn’t work. 🙁

    Hi Truth,

    Mind sharing a screenshot of your WPP current settings? Also, what’s your site URL?

    By the way, just installed a fresh copy of WordPress 3.0 on my personal domain (which is on a shared host) and installed WordPress Popular Posts 2.1.0 on it. Everything works as expected :S

    Can you guys please deactivate all your others plugins and see if it works?

    UPDATE: scratch that. I just moved WordPress to its own directory and tried again – WPP didn’t work. Something is preventing my plugin from communicating with WordPress core hence it can’t update views to the database. This problem doesn’t seem to be affecting sites that have WordPress installed on the root directory, though.

    WordPress Popular Posts 2.1.0 didn’t include an update on its way to communicate to the database, so I suspect this might be a WordPress thing. Will keep on investigating.

    UPDATE 2:

    Alright guys, found a possible workaround. It isn’t as fancy as I would like it to be but it appears to solve the issue with blogs that have WordPress installed somewhere else. If you’re on a hurry, feel free to skip the whole explanation and go see the summary 😛

    This is what I did: I installed WordPress on a subdomain called blog (eg. blog.mysite.com) and then set up WordPress to run on the root domain (eg. mysite.com) by following this tutorial (which I believe most of you did).

    Note that on the tutorial they say that you should set your WordPress address (URL) field to something like mysite.com/blog. Here comes the tricky part: if you set it up as blog.mysite.com (subdomain form, as I did initially) it won’t work since blog.mysite.com is outside your site and for security purposes all web browsers won’t execute cross-domain ajax requests.

    That explains why my plugin couldn’t update to the database all views generated by users. However, if you set WordPress address (URL) to mysite.com/blog (as the tutorial suggests) you won’t have any problems and posts will be cacheable again.

    Summary: check on Settings > General that your WordPress address (URL) field is set to something like mysite.com/blog (or wherever you have installed WordPress) instead of blog.mysite.com. Otherwise, my plugin won’t work.

    I’ve also done some minor updates to my plugin and would like you guys to test it out for me and maybe give me some feedback (bugs, weird behaviors, etc.). Please donwload it here.

    Hi Ikki,

    OK, so I noticed the “Sorry. No data so far.” error about an hour ago. No idea if it has been appearing that way for just today or a few days. Outside of this, I’ve had the plugin running for about 8 months, or more – and have been loving it!

    I meet all the criteria in the FAQ. I’ve not yet upgraded to WP 3.0 – still on 2.9.2. As said, the plugin has been working for months (and I know as recently as last week) and I’ve made no major change to anything WP in the past month or so.

    I tried downloading the link you posted above in “update 2”, but no dice.

    My site is ToonBarn.com, and the plugin widget would appear just below the 300×250 box ad in the right column of ever page.

    Also, to note… an odd number three appears after the title of that section. the title in the widget settings is “Hot Topics at the Barn” and it appears as “Hot Topics at the Barn3”. …maybe that’s a clue…?

    Best,
    Rob

    Under the WP URL, I’ve the correct settings, it’s “http://amourchaleur.com/wordpress”. My actual blog is located at http://amourchaleur.com but the issue still exist. My current setting is:

    <?php if (function_exists("get_mostpopular")) get_mostpopular("range=weekly&order_by=views&limit=3&stats_comments=0&stats_views=0&wpp_start='<ul>'&wpp_end='</ul>'&post_start='<li>'&post_end='</li>'&pages=0"); ?>

    I’ll try out the new version tonight and let you know. Thanks!

    @drkknght: just checked your site and it seems to me you´re still running the official 2.1.0 and not the beta version I posted. Can you please check again?

    @truth: please do let me know the results, ok?

    Tried the new version yesterday but still didn’t fix the problem. I reverted back to the old version.

    Is it possible to remove the “weekly, monthly” text from the output inn the beta version? It’s newly added into the beta version but I would prefer to just list out the posts without any additional text.

    hi ikki — not sure what happened, i guess i didn’t deactivate the old one properly first.

    anyway, i’ve since made sure to upload 2.1.1, and it appears to have worked!! the data is a little buggered – i’m assuming i just have to wait a week or so for it to properly accumulate. oddly enough, i still get that “3” after the section title… no idea where that is coming from, but i can live with it 🙂

    thanks so much for the help with this!!

    best,
    rob

    Am using the latest 2.1.1 on my site now, still having the no data issue.

    Thanks for the continued support Ikki. I had my site configured correctly also i.e. WP was installed in a \blog directory and WP options were setup to point to it. I have now installed your beta and will wait to see what happens.

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘[wordpress popular posts] No data so far.’ is closed to new replies.
Skip to toolbar