WordPress.org

Support

Support » Plugins and Hacks » [Resolved] WordPress plugin repo API tells WP.org sites to upgrade but installs old version

[Resolved] WordPress plugin repo API tells WP.org sites to upgrade but installs old version

  • Wordfence
    Participant

    @mmaunder

    Whenever I release a new version of our plugin to the repo, for a period of a few minutes to an hour WordPress tells me to upgrade, but when I do upgrade it upgrades the plugin to the same (old) version instead of the new version.

    It’s like the API that WordPress.org sites talk to tells WP that there’s a newer plugin version available but the download link still points to the older version for a period of time.

    I’m updating my plugin’s readme.txt and the main plugin.php file with the new version and then I create an appropriately named tag, so I’m pretty sure I’m releasing everything correctly. The plugin is wordfence in case you’d like to take a look.

    Thanks,

    Mark.

Viewing 10 replies - 1 through 10 (of 10 total)
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] WordPress plugin repo API tells WP.org sites to upgrade but installs old version’ is closed to new replies.