Support » Installing WordPress » WordPress/PHP Installation Problem

  • Resolved cchildspi

    (@cchildspi)



    Hello Everyone,

    I just bought a Raspberry PI 3 and in the process of setting it up as a Web Server using WordPress The Raspberry forum folks sent me over here to you all for assistance. I followed the installation tutorial to the letter for setting up APACHE2. Then I get to the WordPress configuration and ran across an issue. The issue seems to be with PHP. It says that I should be getting a WordPress Welcome page, but all I get is:

    “Front to the WordPress application. This file doesn’t do anything, but loads we-blog-header.php which does and tells WordPress to load the theme”

    I even tried to go to the site/wordpress/wp-admin and php code showed up on that page as well. So it seems like php is the cultprit.

    Any ideas on how to continue or fix this?

Viewing 5 replies - 16 through 20 (of 20 total)
  • trying it now…thanks

    Tried it:
    ERROR: Module php does not exist!

    cchildspi

    (@cchildspi)

    Someone on the Raspberry forum told me to try this and IT FINALLY WORKED!

    Tried as suggested:

    sudo a2dismod mpm_event
    sudo a2enmod php7.0
    sudo systemctl restart apache2

    Don’t know what all that means, but I’m glad it worked

    cchildspi

    (@cchildspi)

    You guys are great and very informative. I will try to take your advice and run with it. And as you mentioned ,I did continue the setup as depicted by the tutorial, and I hit a snag at the WordPress Setup page where it wants you to enter: database, user name, password, database host.

    I entered wordpress, root, “mypassword”, localhost.

    Of course i get “Error establishing a database connection”. I just feel like am so close to getting the wordpress setup. I am basically finished with the setup if I can just get this step completed.

    cchildspi

    (@cchildspi)

    Got it, guys and gals. Had to create a superuser for the database

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘WordPress/PHP Installation Problem’ is closed to new replies.