Support » Fixing WordPress » WordPress Permalinks Problem [HELP!]

  • Hello. I just discovered this morning that I have a serious problem with my wordpress blog here(http://codefusionlab.co.cc) I have some posts, which are appearing in the post editor when editing but not when going to its url. For example, this post: http://codefusionlab.co.cc/free-hard-disk-or-partition-imaging-and-cloning-software/ is giving me a 404 error but when I edit it – I can see it allright. However, other posts are looking okay. There are some posts which are having this problem.

    I switched back to the default permalink structure and my post started showing up again, however when I switched back to my default post structure again, the problem appeared again.

    Any suggestions how this might be solved?

Viewing 6 replies - 1 through 6 (of 6 total)
  • however when I switched back to my default post structure again, the

    I mean when I changed to my custom permalink structure, which is %postname%

    Hirvesh, do your links have the “?” in their code, i.e. just before the page number? This is a problem that I have had for some time now. They are only missing in my Related Post section.

    And you might want to read this:
    codex.wordpress.org/Using_Permalinks#Using_only_.25postname.25

    I had this problem and the solution was to go to my ISP (hostmysite.com)and have them set the mod_rewrite on the server. Without this after setting Permalinks, everything goes error 500. The changed links do show but they go nowhere. When you set the mod_rewrite, the FollowSymLinks and other needed directives are also set but you should check to make sure. Some may have access to their server’s configuration to set this but if that’s not the case, contact your ISP.

    iain
    http://www.iainsworld.net

    Hi,

    Set your desired permalink structure and add this code in htaddess;

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Thanks,

    Shane G.

    Only 9 months old, but nice boilerplate.

    😛

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WordPress Permalinks Problem [HELP!]’ is closed to new replies.