WordPress.org

Support

Support » How-To and Troubleshooting » WordPress Permalink 404 issue

WordPress Permalink 404 issue

  • jarodtaylor
    Member

    @jarodtaylor

    Hey guys, I’m having an issue with my permalinks and have no clue why. This hasn’t happened before.

    Anyway, I’m using 2.7.1 on a local setup using Wampserver 2.0h (the latest release).

    For some reason my phpmyadmin had locked me out even though I wasn’t using a password, so somehow I effed my db up and just started over with a fresh install of Wampserver and WordPress. When I immediately install wordpress, and immediately go to permalinks and change away from the default (http://localurl/?p=123) to not only Custom (/%category%/%postname%/) but ANYTHING other than the default, I’m getting a 404 error? I mean, this is with a fresh install of wordpress 2.7.1, no plugins installed, and no posts other than the default that comes with a new WP installation.

    This is what the .htaccess file shows:

    `# BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    and phpinfo() is showing under the apache2handler that mod_rewrite is in the “Loaded Modules”.

    I don’t understand what the problem is. Any help would be appreciated.

    Thanks,

    Jarod

Viewing 3 replies - 1 through 3 (of 3 total)
  • jarodtaylor
    Member

    @jarodtaylor

    Figures, I’ll figure something out 11 minutes after I make the post, even though I have been struggling with this for hours.

    Anyway, I don’t know if this is the only/best fix for it, but if anybody else has this issue.

    I opened up the httpd.conf file and found:

    <Directory />
    Options FollowSymLinks
    AllowOverride none
    Order deny,allow
    Deny from all
    </Directory>

    and changed the AllowOverride none to AllowOverride all.

    Hope this helps someone else before they spend hours of aggravation on it.

    🙂

    I’m having an IDENTICAL problem.

    I’ve just installed wordpress freshly on godaddy (using their auto instal feature) and made a post… then realised I should set the permalinks to /postname/ but got 404’s, and I presumed this was because I’d already started doing stuff.

    So I deleted everything and created a wordpress install and DB freshly once more, and this time changed the permalinks away from their defaults immeadiately, but STILL get 404’s… it’s rendering my hosting POINTLESS unless I can fix it..

    friend,

    am having the same issue. I tried editing .htaccess, altered 404, misc.php and all. But till now its not working. Could you help me? I could not find the file you were telling.

    Thanks. Mine is wp 2.8.4

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress Permalink 404 issue’ is closed to new replies.