Support » Fixing WordPress » WordPress only saves when it feels like it

  • Resolved denravonska

    (@denravonska)


    For some reason we are starting to having huge problems with saving changes made to pages. Sometimes the page will save, sometimes it won’t. I just got this problem with a simple page after doing 4 small changes, adding a little bit of text each time. Now it cannot be saved anymore.

    When it refuses to save we can see that the page revision stays the same. Reloading the page does not help and most of the plugins have been disabled.

Viewing 10 replies - 1 through 10 (of 10 total)
  • @denravonska Sound like caching.

    Purge the cache from any cache plugin you’re using and clear your browser cache too.

    Thread Starter denravonska

    (@denravonska)

    I just tried both clearing my browser cache and using a different computer but with no change. We’re not using a cache plugin.

    Well, the first time on the second computer it didn’t work. The second time the change got through and the revision increased, but now it won’t accept the change again. I click “Update” (or so it says in Swedish), the spinner icon shows up and the page refreshes with the old content. The content has not changed on either computer.

    Also, the change is more likely to go through if I only add 1-3 words instead of the entire sentence but that might just be a coincidence.

    @denravonska

    Understood, thank you for clarifying.

    While you might not be using any caching plugins, some other caching solution may be at work.

    A misconfigured Cloudflare account or inappropriate sever cache settings might be the reason.

    other than that, I am out of ideas.

    Thread Starter denravonska

    (@denravonska)

    I’ll contact my host just in case. The interesting thing is that no data is inserted into the database when this happens so the data is never pushed to the server.

    @denravonska

    Share a link to your website if it’s not private.

    Thread Starter denravonska

    (@denravonska)

    @j09 It is private. The plan was to launch it later today 🙁

    Thread Starter denravonska

    (@denravonska)

    My current hunch is that my host caches the admin pages, causing it to use an incorrect nonce (or something) when saving.

    @denravonska

    Yes, that can happen, admin pages can be cached if caching is not configured properly.

    Since it’s private, there’s not much I can offer as I would just be guessing.

    The only other thing I can think of is to check the response headers to get a hint at what might be responsible for caching.

    Thread Starter denravonska

    (@denravonska)

    @j09 Ok, I’ve figured it out. It stopped working after exactly 3000 character long posts which was too even to be a coincidence. Previously people are recommended to increase max_vars but what worked for me was to increase the POST max value length by adding the following to .htaccess:

    php_value suhosin.post.max_value_length 5000
    php_value suhosin.request.max_value_length 5000

    post.max_value_length cannot be greater than request.max_value_length, so both are needed.

    @denravonska

    Great! I’m glad you got that sorted out! Thank you for sharing your fix!

    Mark this as resolved in case some else runs into the same problem in the future

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WordPress only saves when it feels like it’ is closed to new replies.