Support » Localhost Installs » WordPress on localhost says “UPDATING FAILED” on page update

  • Resolved activestatedesigns

    (@activestatedesigns)


    Hello there,

    I have setup XAMPP on my Mac and successfully transferred my live site over. All seemed to be working by deactivating/deleting/installing plugins. However when I try to update a page/post it gives me the error “UPDATING FAILED”. Can anyone help me troubleshoot why?

    I originally had issues writing plugins to the folder on my computer because the folder privileges were not set to 777. However now I got that to work by having the WP-Content folder 777. Is this by chance similar to what’s happening with updating pages? Is it a different folder?

    Thanks,
    Lorne

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello,

    If you are familiar with the debugs logs can you enable the logs so that you can see when the errors comes from, try debugging and and debugging log on.

    e.g. open your WordPress project directory, and open wp-config.php, then you will find

    -> define(‘WP_DEBUG’, false);

    make this true, and also make one more line after this for debugging,

    -> define( ‘WP_DEBUG_LOG’, true );

    then after check your site, you can see the error logs in project/wp-content folder and the file is debug.log

    after completing do not make false debugging.

    May this will help you.

    Thanks for the response.

    I’m not too familiar with the debug log. Once I create this file. What do i do with it?

    Thanks,
    Lorne

    Hello again,

    So I changed my wp-contents folder and turned the debug to true and added the log line.

    define(‘WP_DEBUG’, true);
    define( ‘WP_DEBUG_LOG’, true );

    I didn’t see a Debug log show up in my wp-contents folder? I went to my site and all, nothing showed up. Any ideas?

    Thanks,
    Lorne

    Hello,

    Are you using wordpress 5.0 or greater ?, because this might be a problem updating page with the New editor.

    Try to install Classic Editor plugin to check whether it’s working or not. Classic Editor

    this is not the Editor issue as mention in this thread Update failed

    Thanks

    Hello mananv,

    Yes I’m using the latest WordPress 5.0.3.

    I installed and activated Classic Editor and it worked! Not sure why that was being funky?

    Now I just need to figure out why I’m receiving this error message on my shop or product pages in WooCommerce, then I’ll be ready to actually work on my localhost site!

    Object not found!

    The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

    If you think this is a server error, please contact the webmaster.

    Error 404

    localhost
    Apache/2.4.37 (Unix) OpenSSL/1.0.2q PHP/7.3.0 mod_perl/2.0.8-dev Perl/v5.16.3

    Thanks for all the help,
    Lorne

    Hello,

    for that can you try to update your permalink?

    go to Settings->Permalinks-> click on Save changes (make sure to take a database backup first)

    and then check your pages.

    I did this this morning an it’s working! Only hiccup was for some reason I can’t write to my .htaccess file so I had to manually create it. After I did that, it worked like it should!

    Thanks,
    Lorne

    Glad that it works,

    make sure to mark it as resolved!

    done and done thanks for the help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WordPress on localhost says “UPDATING FAILED” on page update’ is closed to new replies.