WordPress.org

Support

Support » Installation » [Resolved] WordPress on local network

[Resolved] WordPress on local network

  • Hello!

    I was going to look into some design-changes for my WordPress-site so I installed MAMP and WordPress on my computer to test them out before I started doing any changes to my online site. The problem is this:

    http://gyazo.com/8215b227dd963247b044b095ea0dc0fa.png?1343659481

    What is going on? Is there something with a local network WordPress can’t handle?

    That was with a clean install, when I try just copying and pasting from my webserver to MAMP I can’t access the website. However this would be the prefered way to do it, that is at least what I’ve done previously if I remember correctly!

Viewing 15 replies - 1 through 15 (of 16 total)
  • esmi
    Forum Moderator

    @esmi

    Is there something with a local network WordPress can’t handle?

    Generally speaking, no. I’m currently running 5 WP installs locally without the slightest problem. Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    is at least what I’ve done previously if I remember correctly!

    I’m afraid your memory is playing tricks on you. This has never been the case. See Moving_WordPress.

    Well, the picture is from a totally clean install of WordPress, that’s what I don’t get? Meaning every of your solutions won’t work. :S

    I will try using a sub-domain on my web-server to test it out now, MAMP has always been a problem for me. And thanks for the “Moving-WordPress” link. 🙂

    esmi
    Forum Moderator

    @esmi

    Really? How can you be sure that you didn’t have a corrupt WordPress download?

    I tried multiple downloads, but I’ll guess I can try one more time. One question though:

    If I copy/paste from my webserver to local, I have to go into phpbbMyAdmin and change the URLs if I understood the guide correctly?

    I have gotten this to work previously, wonder what I do wrong this time. 😛

    esmi
    Forum Moderator

    @esmi

    In the local copy of your database, yes.

    It looks like my webhosts backup-system didn’t do a complete backup, including all tables such as siteurl, so I guess I have to do a manuall backup, then I’ll try. Thanks for the help so far, I’ll post when I have tried this out again. 🙂

    Okey, so I got in now. Two problems, I can’t get into anything but the front page and the front page is CSS-free for some reason. Do you know anything about that? :S

    esmi
    Forum Moderator

    @esmi

    Sounds like you didn’t change all of the urls…

    The guid-table for posts still have my websites URL. Do you know exactly where to change this? I changed both “Home” and “siteurl” in wp_options.

    esmi
    Forum Moderator

    @esmi

    Sorry – the guid table? Try using http://wordpress.org/extend/plugins/search-and-replace/ to replace the urls across all tables.

    GUID-column I guess, sorry, not too advanced on this as you can tell. Thanks for the plugin, but I still have to get into wp-admin to install it though.

    Tried deactivating all plugins through phpMyAdmin btw, didn’t work.

    esmi
    Forum Moderator

    @esmi

    Suggestion: re-install WordPress locally and then use Tools -> Export/Import to import your site’s content rather than trying to carry out a database move.

    Sure, I just hope it won’t fail on me like I showed in the picture before.

    Finally everything works! Thank you SO much! 🙂

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] WordPress on local network’ is closed to new replies.