WordPress.org

Support

Support » How-To and Troubleshooting » WordPress on IIS 7 – plugin update problem

WordPress on IIS 7 – plugin update problem

  • hi

    I’ve moved my WP blog a IIS machine. Everything is running perfect except one thing – auto-updates for plugins. When I click the auto-update option in the plugins menu WP gives me a message saying:

    Unpacking the update.
    Installing the latest version.
    Deactivating the plugin.
    Removing the old version of the plugin.
    Could not create directory. DIRECTORY\wwwroot/wp-content/plugins/akismet/
    Plugin upgrade Failed.

    And whats even stranger it removes the plugin enteirely and the plugins directory is not even avaiable in Windows Directory.

    Any suggestions how can this be fixed?

Viewing 15 replies - 16 through 30 (of 34 total)
  • I was still unable to do delete an inactive plugin through the admin side with wincache enabled.

    I am able to consistently repro this bug on PHP 5.2. I am not able to reproduce this with PHP 5.3. It looks to me that this is a problem specific to PHP 5.2. Has anybody run into this with PHP 5.3?

    Why is anyone granting IIS write permissions to their core wordpress files?

    This is security madness!

    Create a separate FTP only account with write priviliges such that you need to “elevate priviliges”, you can do so.

    Zonkz, are you talking about me or someone else? Are the plugins considered core wordpress files? I don’t know much about security stuff, so any articles that you think are worth reading, I’d love to hear about.

    ruslany, I have PHP 5.3.1 installed.
    Build Date Nov 19 2009 09:48:59

    @pdoteam: are you seeing this bug even with the latest build of WinCache for PHP 5.3 (file version 1.2.1010.0)?

    Yes I tested 1.2.1010.0 yesterday.

    You are right, I am able to repro this with PHP 5.3 as well now.

    Just to clarify:
    a) this is an issue with WinCache for PHP
    b) it’s not fixed yet
    c) setting the WP App Pool as a separate user does not fix it

    I am running WP 3.0.5 on Windows Server 2008/IIS 7.0 using PHP 5.2. I tried the solution at:
    http://www.whitworth.org/2009/03/10/plugin-upgrade-failed-in-wordpress-using-iis-7/
    ..but it didn’t work.

    It doesn’t appear that upgrading from PHP 5.2 to 5.3 will fix it, either, and I’m not eager to make such a major updgrade to our production blog (I’m much more of a webmaster than a dev) in “hopes” it will work.

    Has anyone been able to get auto updates to work in IIS?

    I have the issue on Windows Server 2003/IIS 6.0, with php 5.3. I had to stop using WinCache.

    Note that you do not have to stop using WinCache because of this. Just disable it temporarily while upgrading your plugins and then enable it back.

    The bug is not yet fixed in wincache. The fix turned out to be much more involved than originally anticipated.

    Hello all, great info here. As far as I know, WinCache has never been used on this box, but I’m still having the issue of not being able to update plugins.

    Win2003 SP2
    IIS 6.0
    PHP 5.2.3
    MySQL 4.1.11-nt
    Wordpress 3.1

    Any ideas on this?

    Hi there,

    I have experienced also the same problem. I am running my wordpress websites on:
    Windows Web Server 2008 R2
    IIS 7.5
    PHP 5.2.17
    MySQL 5.1
    Application Pools (shit, so many options) I have got this one:
    Managed Pipeline Mode: Classic
    Itentity: LocalSystem

    What I did and helped to fix my updates is:
    I checked my plugins folder Security tab and added IUSR and ticked Allow Modify. This helped to install all plugins. My friend set IUSR on a whole wordpress application so he could update also to 3.1 with no problem.

    I cannot recommend this as I don’t know if it is safe to use IUSR on these folders. Yes, the IUSR user wasn’t automatically installed/added when the wordpress was installed. Should it be there or not? WordPress was working without that, also adding new plugins was working. The only problem was update…

    Can anybody advise if this is safe???

    @vaclavelias

    I have a new install of WP on IIS7 like you. I used the Web Platform Installer to deploy both the initial WP/PHP/MySQL install as well as the site.

    The IUSR account was already set with Modify rights on the plugins dir for me. Si I would say it’s safe.

    I also have this problem when trying to upgrade both plugins or WP (to 3.1). I’m using the latest WinCache version (Version 1.1.0630.0 Build Date Jun 29 2010 10:58:05). Disabling it do not correct the issue for me for updating WP or plugins.

    This looks like an NTFS permission issue to me but PHP is all new to me too and I’m not sure what permissions are granted through the related services.

    I’m going to use some monitoring tools to see what credentials are trying to write to the wp-content directories during the upgrade. I’ll keep you all posted.

    When is a new version of WinCache that fixes this expected to be out?

    Another workaround to try is to turn off file change notification in wincache by setting the following in php.ini file:

    wincache.fcndetect = Off

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘WordPress on IIS 7 – plugin update problem’ is closed to new replies.
Skip to toolbar